the red line for a leak is outside the map so i dont know what is causing the problem

Discussion in 'Mapping Questions & Discussion' started by basilhs333, Aug 11, 2017.

  1. basilhs333

    basilhs333 L9: Fashionable Member

    Messages:
    600
    Positive Ratings:
    163
    i am almost done with a new version of cliffedge and i redone the skybox and stuff just to make it better and stuff. i finished it and i saw that i succeded in doing so. no more leaks on the map caused by a prop for example getting out from the map to the void so i decided lets redo the red spawn's doorway just to be better.
    i changed only one doorway by moving it up instead of being down. i blocked all the holes that could caused a leak and i was supriced to see there was a new leak. the red line which shows the prop for example that causes the problem was outside the map on the void only which is
    a leak that i cant fix for some reason cause ,i dont know where and what is causing it. yes i can go to interlopers.net/error which i did and it says that the func_respawnroom causes the problem . i decided lets do some tests like unchecking the custom box and it said no leaks/errors. that was weird i thought. what can cause that problem?
    if i could get an aswear as soon is possible i would very appreciate it. thanks for the help.
     
  2. Vel0city

    aa Vel0city func_fish

    Messages:
    1,931
    Positive Ratings:
    1,540
    Entity origins can also leak. Look up the VDC article on leaks, it has a section about mismatched entity origins.
     
    • Thanks Thanks x 1
    • Like Like x 1
  3. A Bucket

    A Bucket L4: Comfortable Member

    Messages:
    193
    Positive Ratings:
    180
    Yea, watch for large entities (like waterfalls or treeplanes) that are near the edge of the map because their origin can leak, aka be outside the map.
     
    • Thanks Thanks x 1
  4. basilhs333

    basilhs333 L9: Fashionable Member

    Messages:
    600
    Positive Ratings:
    163
    guys thank you so much you were really helpedful! i now fixed the problem thanks to you thanks.
    i redone the func_respawnroom and such on last and it worked fine now . thanks again
     
    • Like Like x 2