.TGA is bogus!

Discussion in 'Mapping Questions & Discussion' started by Spammish, Feb 15, 2010.

  1. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    I'm trying to create a custom overlay for my map, I saved it as a .tga and placed it in an overlays folder within my materialsrc folder, the problem is every time I drag it to the vtex icon and the dos prompt comes up it states the .tga is bogus, the developer wiki says "The texture image you are trying to convert is not recognized as a valid targa (.tga) file. Make sure that it is, and that it is either 24 bit/pixel or 32 bit/pixel. (16 bit/pixel is not recognized.)" How would I check this?
     
  2. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Are the dimensions both a power of 2?
     
  3. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    if i remember correctly it was 512 x 256 pixels but I'll go back and check
    Edit: Yup, 512 x 256 pixels
    Edit: The first one was set to RGB 8 bit, I created a second one and set it to RGB 32 bit and I still have have problem.
     
    Last edited: Feb 15, 2010
  4. Cynick

    Cynick L4: Comfortable Member

    Messages:
    153
    Positive Ratings:
    143
    I had a problem with a RLE-Compressed TGA a while back. If your image is compressed, try an uncompressed version.
     
  5. Tehrasha

    Tehrasha L3: Member

    Messages:
    115
    Positive Ratings:
    26
    THIS.

    That was my first thought upon reading the problem anyway...
     
  6. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    I haven't compressed it, it's straight from photoshop, my first (8-bit) image was about 300kb whereas my second (32-bit) image was about 3000kb if that helps.
     
  7. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
  8. MrAlBobo

    MrAlBobo L13: Stunning Member

    Messages:
    1,059
    Positive Ratings:
    219
  9. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    You read my mind, I wondered if this would work because I remember using it to make sprays, I'll have a go and report back.
    Edit: Stupid me, I didn't merge the layers :facepalm: Problem solved guys, thanks for all your help. :thumbup1:
     
    Last edited: Feb 16, 2010
  10. Tehrasha

    Tehrasha L3: Member

    Messages:
    115
    Positive Ratings:
    26
    Photoshop lets you save .tga with layers intact? Or the VTF plugin allows it?

    Either way.. that needs fixed.
     
  11. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    The VTF plugin merges all visible layers, TGA saving does not.
     
  12. Tehrasha

    Tehrasha L3: Member

    Messages:
    115
    Positive Ratings:
    26
    AFAIK the TARGA format does not support layers at all, and for Photoshop to not account for that when saving is a serious error. Even poor little GIMP knows better when exporting .tga images.
     
  13. Spammish

    Spammish L3: Member

    Messages:
    117
    Positive Ratings:
    33
    Ye, thats how I found out, I switched to my pc from mac (with my mac having ps and my pc having gimp) and opened it in gimp then re-saved it and the option came up to merge it, I don't have the vtf plugin, I can't seem to get it to work on the mac version, nonetheless I got it working, had a black background at first but that was fixed, came out just as I wanted except the font was a bit low res for my needed sizing.