TF2 stuttering on me

Discussion in 'Team Fortress 2 Talk' started by MrSinistar, Apr 11, 2008.

  1. MrSinistar

    MrSinistar L2: Junior Member

    Messages:
    82
    Positive Ratings:
    6
    This is driving me insane. TF2 is randomly pausing during gameplay and stuttering for like 5 seconds before going back to gameplay. This started happening after working on my new map and this effects other maps too.

    Any help would be appreciative.
     
  2. Spike

    Spike L10: Glamorous Member

    Messages:
    716
    Positive Ratings:
    82
    I have had the same problem 2 times while playing, but only today
     
  3. drp

    aa drp

    Messages:
    2,251
    Positive Ratings:
    2,551
    are you running dx9? change to dx8 and you'll be fine.
     
  4. phatal

    phatal L6: Sharp Member

    Messages:
    259
    Positive Ratings:
    21
    I have this happen to me but with only 1 map (cp_warpath). I use vsync enabled because I have an LCD and if I disable the vsync the stuttering goes away. Don't know if it's related but thought I would throw that out there.
     
  5. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    I am on dx8 and it stutters for about 30 seconds... =\
     
  6. MrSinistar

    MrSinistar L2: Junior Member

    Messages:
    82
    Positive Ratings:
    6
    After some research, I found out that other people are experiencing this problem as well...including my friend (and he has a way better computer than me)

    Maybe the latest patch did something to the game, because my game is running on pretty low settings (Hardware DX8.1, according to my video settings menu) and this has never happened before. (No HDR, no bloom and simple reflections)

    I've heard that running the game in windowed mode might help, so I'm going to see if that works.
     
  7. Deadeye2007

    Deadeye2007 L2: Junior Member

    Messages:
    52
    Positive Ratings:
    0
    I have very high end specs and its doing it to me too - but only recently. Something has gone nutty.
     
  8. MrSinistar

    MrSinistar L2: Junior Member

    Messages:
    82
    Positive Ratings:
    6
    It's still doing it to me and it's driving me insane.

    I heard that uninstalling Avast Antivirus fixes the problem, but that's just ridiculous, IMO. I love Avast and it hasn't given me any trouble with any games in the past whatsoever, until Valve messed around with the source code and did something to TF2 that makes it unplayable. That makes me very angry, especially since I only make maps for TF2.

    Checking out Garry's Mod, I noticed I had good FPS and no stuttering at all, so this definitely is a TF2-only prob.
     
  9. pushBAK

    pushBAK L1: Registered

    Messages:
    1
    Positive Ratings:
    2
    i turned off audio Hardware Acceleration and it got rid of the kind of stuttering you are describing...

    i describe it here where i found my help

    http://forum.sysinternals.com/forum_posts.asp?TID=837&PID=77782#77782

    but basically:
    --going to Settings, Control Panel, Sounds and Audio Devices, Speaker Settings Advanced, Performance and turning off Hardware Acceleration entirely.--

    thats what worked for me...

    good luck!
     
    • Thanks Thanks x 2
  10. crazychicken

    crazychicken L2: Junior Member

    Messages:
    93
    Positive Ratings:
    7
    i have this too
     
  11. luxatile

    aa luxatile deer

    Messages:
    2,289
    Positive Ratings:
    1,348
    I also have some weird lag problems. I'm open for anything, so I will try pushBAK's suggestion. :)

    I have a program called WLAN Optimizer running too, which calms down the lag a bit, but it doesn't completely eliminate the problem. I don't remember where I found it, but it's probably worth a Googling.
     
  12. Dox

    Dox L8: Fancy Shmancy Member

    Messages:
    588
    Positive Ratings:
    62
    the game has been doing this to me for awhile... i thought it was lag, which was odd since it happens on servers for which my ping is <40... i how one of the above solutions will help... it just freezes for 2-4 seconds then unfreezes...
     
  13. Dox

    Dox L8: Fancy Shmancy Member

    Messages:
    588
    Positive Ratings:
    62
    Sorry to double post, but need to bump the thread since my problem is newish and its would just be buried and unanswered if not bumped. I set my -dxlevel 80 on team fortress 2's settings, but ingame options now show DX level to be 8 for hardware but still 9 for software... Is this a problem and how would I change the software DX level?
     
  14. drp

    aa drp

    Messages:
    2,251
    Positive Ratings:
    2,551
    more than likely you will be running tf2 on dx hardware. so you are playing with dx8 enabled. has the stuttering stopped?

    one more thing you might want to try is to disable the hardware accelation for your sound.

    Start > Run > "dxdiag"

    go to the sound tab, and notch back the acceleration slide.
     
  15. Dox

    Dox L8: Fancy Shmancy Member

    Messages:
    588
    Positive Ratings:
    62
    im running vista, no sound acceleration bar in my dxdiag...
    updated my graphics driver and have hardware settings on 8 and no change...