TF2 Crashes When I Load My Map

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

CHIM

L1: Registered
Dec 18, 2017
6
I'm working on a simple KOTH map which makes use of the Mayann Prop Packs' textures. The map seems to compile fine (putting it through interlopers confirms this is the case) but when I run it (or load it through a normally launched TF2 and the 'map' command) the game crashes shortly after it arrives at the "Welcome to Team Fortress 2" chalkboard screen. The dump file says that error was "The thread tried to read from or write to a virtual address for which it does not have the appropriate access" (0xC0000005). I've tried to reboot the computer, but it doesn't help. Here's some extra information, in case it helps:

PC Specs (from Steam -> Help -> System Information):

Code:
Computer Information:
    Manufacturer:  LENOVO
    Model:  80V5
    Form Factor: Laptop
    Touch Input Detected

Processor Information:
    CPU Vendor:  GenuineIntel
    CPU Brand:  Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
    CPU Family:  0x6
    CPU Model:  0x8e
    CPU Stepping:  0x9
    CPU Type:  0x0
    Speed:  2712 Mhz
    4 logical processors
    2 physical processors
    HyperThreading:  Supported
    FCMOV:  Supported
    SSE2:  Supported
    SSE3:  Supported
    SSSE3:  Supported
    SSE4a:  Unsupported
    SSE41:  Supported
    SSE42:  Supported
    AES:  Supported
    AVX:  Supported
    CMPXCHG16B:  Supported
    LAHF/SAHF:  Supported
    PrefetchW:  Unsupported

Operating System Version:
    Windows 10 (64 bit)
    NTFS:  Supported
    Crypto Provider Codes:  Supported 311 0x0 0x0 0x0

Video Card:
    Driver:  Intel(R) HD Graphics 620
    DirectX Driver Name:  igdumdim32.dll
    Driver Version:  22.20.16.4836
    DirectX Driver Version:  22.20.16.4836
    Driver Date: 10 17 2017
    OpenGL Version: 4.5
    Desktop Color Depth: 32 bits per pixel
    Monitor Refresh Rate: 60 Hz
    DirectX Card: Intel(R) HD Graphics 620
    VendorID:  0x8086
    DeviceID:  0x5916
    Revision:  0x2
    Number of Monitors:  1
    Number of Logical Video Cards:  1
    No SLI or Crossfire Detected
    Primary Display Resolution:  1920 x 1080
    Desktop Resolution: 1920 x 1080
    Primary Display Size: 13.54" x 7.60" (15.51" diag)
                                            34.4cm x 19.3cm (39.4cm diag)
    Primary Bus Type Not Detected
    Primary VRAM: 1024 MB
    Supported MSAA Modes:  2x 4x 8x 16x

Sound card:
    Audio device: Speakers (Realtek High Definiti

Memory:
    RAM:  8036 Mb

Miscellaneous:
    UI Language:  English
    Media Type:  Undetermined
    Total Hard Disk Space Available:  1111787 Mb
    Largest Free Hard Disk Block:  641000 Mb
    OS Install Date: Dec 31 1969
    Game Controller: None detected
    VR Headset: None detected

The compile log: https://gist.github.com/WizardCarter/f2fa4694dfe35458536574197388c37b

The dump file: http://www.mediafire.com/file/z62g6z7blrvizkj/crash_hl2.exe_20180424192314_1.dmp
 

CHIM

L1: Registered
Dec 18, 2017
6
I hate to bump my first thread like this, but I really could use the help and I haven't a clue how I would even start to solve this.
 

CHIM

L1: Registered
Dec 18, 2017
6
I did try to verify the game files, but there was no change to the crash.
 

Da Spud Lord

Occasionally I make maps
aa
Mar 23, 2017
1,341
No, I mean repairing your library folder:
Repair Library Folder
The Steam library folder contains all of your installed games on disk. These folders need to be writable by all users in order to update properly. Sometimes these user permissions break and need to be refreshed.

Navigate to your Steam -> Settings -> Downloads -> Steam Library Folders -> Right click on folder -> Repair Folder
 

CHIM

L1: Registered
Dec 18, 2017
6
After repairing the library folder and restarting the computer, the same crash occurred.
 

Narpas

Takes way to long to make and update maps
aa
Jun 11, 2015
429
In-game crashes that still compile correctly are often due to entity logic; I'd suggest making sure that all your inputs and outputs are correct, and that you aren't including an object in it's own hierarchy (i.e. parenting it to an entity that is parented to the original)
 

CHIM

L1: Registered
Dec 18, 2017
6
The crash occurred after applying some textures. I don't think it was entity work. Is there any chance that the texture application changed it? If not, is there a way I could search for any of those entity logic errors?
 

Narpas

Takes way to long to make and update maps
aa
Jun 11, 2015
429
Generally with logic errors you'll have to find the thing yourself; however you can also use alt+p to open the problem checker. If you still can't find what's causing it, try using the cordon tool to test small parts of the map, and see where it crashes and where it doesn't, and then just narrow it down from there
 

Crash

func_nerd
aa
Mar 1, 2010
3,243
I'd try cordoning the map off in chunks, compiling, and seeing if it crashes. Cut the map in half, compile, test, if it crashes cut that in half and try again. If it doesn't, switch to the opposite half you first tried and go from there.

It's sort of the brute force method of narrowing down problem locations.
 

henke37

aa
Sep 23, 2011
2,075
Try turning on console logging to file. And then switch on I/O debugging.
 

CHIM

L1: Registered
Dec 18, 2017
6
Cordoning did nothing to halt crashes. No matter where I put the box, the games still crashed when I load the map. In fact, I even made a new room separate from the map's original geometry and cordoned it, but the game still crashed. I also tried to delete all files related to the map (except for the .vmf, of course) but the crash still occurred. This led me to believe that something was wrong in the map properties, and wouldn't you know it, I was correct. Apparently, setting "Display Game Title" to "Yes" causes crashes. That's what I get for not compiling more often, I suppose. Anyway, thank all of you for any help provided.