Texture Error

Discussion in 'Mapping Questions & Discussion' started by Curtain_Pole, Dec 29, 2012.

  1. Curtain_Pole

    Curtain_Pole L1: Registered

    Messages:
    42
    Positive Ratings:
    11
    Hello, I have applied the following texture: "blendrockgroundwall004" to a displacement and blended the texture using the paint alpha tool. However it would seem the alpha layer does not like being rendered as in game it produces this effect:

    https://dl.dropbox.com/u/24546869/2012-12-29_00002.jpg

    I have multiple displacements in my map using a range of blend textures. However it seems that this is the only blend texture causing this problem. If anyone has any ideas on how to fix this then please leave a reply.

    I have also attached the latest compile log just in case.

    Link to Compile Log: https://dl.dropbox.com/u/24546869/compilelog.txt
     
  2. Faux Rhinoceros

    aa Faux Rhinoceros Also known as Dr. Element

    Messages:
    1,471
    Positive Ratings:
    1,363
    As far as i can see, there are several issues regarding your displacements.

    Paste your compile log here and look for yourself. Perhaps once those buggers are fixed, it will work normally.
     
  3. The Asylum

    aa The Asylum

    Messages:
    1,658
    Positive Ratings:
    439
    Or you could keep it like that and make the Green Hill Zone

    [​IMG]
     
  4. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,031
    Positive Ratings:
    3,975
    You have a missing or invalid blend mask in the VMT. I know there's at least one stock texture that does this.
     
  5. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    One of those textures (the ground I think) doesn't have a normalmap but one is enabled in the .vmt, so you get that effect. Use a different texture or disable the normalmap.
     
    • Thanks Thanks x 1
  6. Curtain_Pole

    Curtain_Pole L1: Registered

    Messages:
    42
    Positive Ratings:
    11
    That is indeed the cause of the problem, by disabling the normap map in the .vmt file this eliminates the problem. The original .vmt file within the gcf read as follows;

    Code:
    "WorldVertexTransition"
    {
    	"$basetexture" "Nature/rockwall004"
    	"$basetexture2" "Nature/rockground001"
    	"%tooltexture" "Nature/blendrockgroundwall004_tooltexture"
    	"$bumpmap" "Nature/rockwall004_bump-ssbump"
    	"$bumpmap2" "Nature/rockground001_bump-ssbump"
    	"$ssbump" "1"
    	"%keywords" "tf"
    	"$surfaceprop" "dirt"
    }
    By removing the line "$bumpmap2" "Nature/rockground001_bump-ssbump" this eliminates the problem, removing the black squares and leaves a nice clean texture. Rather annoyingly though this isn't a custom texture so it looks like i will be packing the new .vmt file along with the map.

    Thanks guys
     
  7. henke37

    aa henke37

    Messages:
    1,836
    Positive Ratings:
    420
    At least you don't need to pay for the vtf.