1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Team errors?

Discussion in 'Mapping Questions & Discussion' started by Hypn0s, May 26, 2017.

  1. Hypn0s

    Hypn0s L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    So I'm making my first TF2 map and it was all going good until I made my spawn rooms. The RED spawn room works fine, and I did the exact same thing for the BLU team, (besides the team variables) but they didn't work. I then tried making a resupply cabinet for both teams, but it only worked for BLU. Anyone know what might be happening?
     
  2. henke37

    aa henke37

    Messages:
    1,954
    Positive Ratings:
    465
    Define "didn't work". And list the keyvalues of all involved entites.
     
  3. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    876
    Positive Ratings:
    594
    A screenshot works too.
     
  4. Hypn0s

    Hypn0s L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    image.png
    The team is set to Blue, but it doesn't regenerate health an ammo.
     
  5. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    876
    Positive Ratings:
    594
    Hmm... I'm guessing the cabinet doesn't animate either?

    Any errors in your compile log?
     
  6. Diva Dan

    aa Diva Dan hello!

    Messages:
    858
    Positive Ratings:
    1,480
    If you're copying things from one team to another, use paste special and select "make all entity names unique". Things with similar names can create conflicting interactions even after changing the team value.

    Also, in the original post you say it only works for blue, but then say it doesn't work for blue- which is it :p?
     
  7. Hypn0s

    Hypn0s L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    Sorry, I ment it only worked for RED
     
  8. Hypn0s

    Hypn0s L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    I did not copy them.
     
  9. Hypn0s

    Hypn0s L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    Turns out i was spawning in the wrong spawn because my BLU spawns were 1 hammer unit inside the ground
     
  10. henke37

    aa henke37

    Messages:
    1,954
    Positive Ratings:
    465
    And this is why we color code the spawns even in pre-alpha.