Swamp theme Error(s)

Discussion in 'Mapping Questions & Discussion' started by rjackson, Aug 15, 2009.

  1. rjackson

    rjackson L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Hey there, I'm building a map with the swamp theme (I'm not using it for the contest though, unfortunetly. It won't be super-detailed).

    Anyway, I'm having a few problems.
    1: Using the 2d skybox texture (same error with regular skybox texture), the skybox appears fine on the top side, but front, left, back and right all seem to be 'stretched' from the edges of the up texture or are a mirror of the "up" texture.
    I plan to build a 3d skybox soon, so this isn't a huge problem for the final version of my map.

    2: - my main issue: Using the water provided with the theme pack, the reflection of it shows as pink. This is ofcouse due to an error with cubemaps. However, when compiling the map and/or building cubemaps (in game) I am presented with this error (quoted from compile log):

    As said, #2 is my main worry. Is there a way I can easily solve this issue as soon as possible, - the maps relatively small and I'm hoping *may* be released for testing at the end of the day.

    Thanks.
     
  2. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    You will always get the skybox error, but nothing is wrong. See my sig for more info on cubemaps.
     
  3. rjackson

    rjackson L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    The problem is that I am unable to build my cubemaps, due to the skybox error.

    "Can't load skybox file skybox/sky_night_03 to build the default cubemap!"
     
  4. Engineer

    aa Engineer

    Messages:
    1,166
    Positive Ratings:
    372
    No, you did everything right, its just a silly error, imagine that its not there.
     
  5. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    yeah, everyone gets that, just follow the steps from Cameron´s writeup and everything will be fine, ignore the errors

     
  6. rjackson

    rjackson L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Ah thanks. It does work.

    I have another issue, where 2 brushes (for the ground) meet, I get some sort of 'shadow' issue? I've checked and both of the brushes are on the same level as eachother, so there should be no casting of shadows from one onto the other.
     
  7. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,531
    Are those brushes displacements? and if so did you make the entire brush into displacements? Only the faces you need (top) should be.