Suddenly, leaks. Leaks everywhere.

Discussion in 'Mapping Questions & Discussion' started by LuisReefTank, Mar 26, 2011.

  1. LuisReefTank

    LuisReefTank L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Hello, i have a big problem, and its really pissing me off.
    My map used to compile just fine, i used to play it, but at a point o acidently corrupted the map file and had to decompile my last playable version and start again. alright cool no problem, then i compiled it was all good except for the cube maps witch where not compiling currectly.
    Still i continue my work, i go compiling and compiling and testing several versions.
    Until my last version, with all the triggers that previously worked.
    Suddenly hammer detects leaks everywhere. Suddenly all my props are considered leaks, my teleport destinations, triggers, everything, what happend?
     
  2. REEJ

    REEJ L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    176
    I never got any leaks from decompiling.
    Anyway, map -> load pointfile (in case you didnt use it)
     
  3. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    5,463
    I'm assuming thats how he knows everythign is a leak...

    Remember displacements and (i think) func_detail 's DON'T seal a map...

    It also might be an invalid solid error, if you have done any vertex manipulation recently, look at that, or just alt+p to check.
     
  4. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    299
    Does the compiler think all the props are outside the map?

    I once had this problem; I removed all the optimisation brushes (visclusters, hints...) and remade them. That worked for me.