Stuff is fading in and out of existence.

Discussion in 'Mapping Questions & Discussion' started by CrippledDonut!, Jan 12, 2018.

  1. CrippledDonut!

    CrippledDonut! L1: Registered

    Messages:
    38
    Positive Ratings:
    1
    When I am in hammer some blocks will disappear and reappear while I am flying around and it is kind of annoying because sometimes I go to texture stuff and it will disappear when I go to apply the texture. Does anyone know whats going on.
     
  2. hamsterkins

    hamsterkins L1: Registered

    Messages:
    30
    Positive Ratings:
    5
    Could you possibly post a screenshot of what is happening? Thank you!
     
  3. Erk

    aa Erk erk

    Messages:
    305
    Positive Ratings:
    738
    Alright so first thing you want to do is go to Tools.

    [​IMG] Which looks like this

    [​IMG]

    The tools tab is up on the top of the menu for hammer.

    Then you want to go all the way down to the bottom bit where it says Options.

    Click on that you'll get this.

    [​IMG]

    (Ignore the fact that this is for GMod I had that setup open when I was looking at this)

    [​IMG]

    You wan to then click on 3D views which lets you change the render distance (when the block bits replace the models)

    Turning the Model render distance all the way up will stop the model from swapping out with the box.

    [​IMG]

    Making your props go from this-
    [​IMG]

    [​IMG]

    - To being fully rendered.
     
    Last edited: Jan 12, 2018
  4. CrippledDonut!

    CrippledDonut! L1: Registered

    Messages:
    38
    Positive Ratings:
    1
    nevermind. I closed hammer and reopened it and everything was fine
     
  5. Gorgonzilla

    Gorgonzilla L3: Member

    Messages:
    108
    Positive Ratings:
    41
    It's possible that you have Radius Culling on, but I think props/ world geo hide after a certain distance. This hides parts of your map when you're too far away, turn this off for when you are compiling, because when left on, it can make parts on your map not load, if they were being hidden by the Cull.
     
  6. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    721
    Positive Ratings:
    495
    I don’t think either model render distance nor radius culling are the issue CrippledDonut is describing. It’s a bug where sometimes when you’re working with a brush, it will randomly decide to vanish unless you look at it from certain angles. I don’t know what causes it, but restarting Hammer is the only fix I’ve found for this issue.
     
    • Agree Agree x 1
  7. Gorgonzilla

    Gorgonzilla L3: Member

    Messages:
    108
    Positive Ratings:
    41
    Ah yeah, I've had that happen as well, but i have no idea if there's a fix.
     
  8. BigfootBeto

    aa BigfootBeto Too obsessed with perfection

    Messages:
    371
    Positive Ratings:
    569
    The fix is to grab the brush when it appears, delete it (or ctrl+x) and then undo to bring it back.
     
    • Thanks Thanks x 1
  9. CrippledDonut!

    CrippledDonut! L1: Registered

    Messages:
    38
    Positive Ratings:
    1
    Thats what was happening to me.