StudioMDL making my collision model into a single convex shape

Discussion in 'Mapping Questions & Discussion' started by Psy, Sep 19, 2009.

  1. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,468
    I have a collision model split into 3 parts and each part has it's own smoothing groups. When I compiled it, studiomdl makes it 1 single convex shape for some reason.

    [​IMG]

    But when I remove one of the parts it will recognise each part as its own convex shape like this.

    [​IMG]

    Here's the .QC

    Code:
    $staticprop
    $origin 0 0 0 270
    $cd "C:\Users\Aaron\Desktop\Nightfall\models_src"
    $modelname "props_nightfall/door_176x144.mdl"
    $model "body" "door_176x144.smd"
    $cdmaterials "models\props_nightfall\"
    $surfaceprop "wood"
    $sequence ref "door_176x144_ref" fps 30.00
    $collisionmodel "door_176x144_phys.smd" {
    	$convex
    	$mass 80.0
    	$inertia 1.00
    	$damping 0.00
    	$rotdamping 0.00
    }
    Here's the compile log

    Code:
    Building binary model files...
    Working on "door_176x144.qc"
    SMD MODEL C:\Users\Aaron\Desktop\Nightfall\models_src/door_176x144.smd
    SMD MODEL C:\Users\Aaron\Desktop\Nightfall\models_src/door_176x144_ref.smd
    SMD MODEL C:\Users\Aaron\Desktop\Nightfall\models_src/door_176x144_phys.smd
    Model has 1 convex sub-parts
    Collision model completed.
    EDIT: D'oh. Each part had to be attached.
     
    Last edited: Sep 19, 2009
  2. jpr

    aa jpr

    Messages:
    1,095
    Positive Ratings:
    507
    I've had this problem too before. You have to add a bone, iirc
     
  3. Acumen

    aa Acumen Annoyer

    Messages:
    704
    Positive Ratings:
    594
    you should apply only one smoothing group to the collision model - no need to have more of them on a collision model
    when you attached all parts to your editable mesh/poly you should not weld the vertices together. every single piece should be selectalbe via "Elements" dialog

    edit: kk, just tested it. don't really know how you did it, but could it be, that you have one sealed model shaping the frame - like an actual model ? i can't really tell whether you have 3 individual model parts or one welded together -
    so i'll just explain how i got mine to working.
    first i created my 3 intersecting boxes. attached them in one object. assigned only one smoothing group. didn't weld any vertices. exported, compiled, happy :)
    that's how valve does it on their door frames as well, btw.

    if it's not clear, i'd be glad to take pictures :)
     
    Last edited: Sep 20, 2009
  4. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,468
    Erm, I've fixed it already as stated at the end of the first post. :p
     
  5. Acumen

    aa Acumen Annoyer

    Messages:
    704
    Positive Ratings:
    594
    meh, you know the golden forum rules. no one-lined text after images posted :D