Static Props Disappear/Reappear (Optimization Issue?)

Discussion in 'Mapping Questions & Discussion' started by TheNoobThatWas, May 15, 2017.

  1. TheNoobThatWas

    TheNoobThatWas L1: Registered

    Messages:
    17
    Positive Ratings:
    3
    I've been trying to compile an edited version of cp_gorge, but I'm having a problem specific to nearly all static props within the building the holds the final control point.
    Standing in certain places causes them to disappear, and when you move closer they suddenly appear, or flicker in and out as you move. Most of the props are static, and are set not to fade out. For example, these include the control point itself, railings around edges, and pipes on the walls.
    I believe it has to do with hint brushes or area portals, but the problem is beyond my level of understanding. Compiling without tool brushes removed the problem, so even though that's an awful solution, I'd like to figure out how to fix the optimization in the area, rather than removing parts of it.
     
  2. iiboharz

    aa iiboharz Meme Queen

    Messages:
    700
    Positive Ratings:
    1,025
    If you're using a decompiled version of a map as a base the areaportals have most likely broken, your best bet is to re-make all of them from scratch probably.
     
  3. TheNoobThatWas

    TheNoobThatWas L1: Registered

    Messages:
    17
    Positive Ratings:
    3
    I can do that, but some problem parts only contain hints, and not portals. Should those be removed, or should I look into redoing them as well?
     
  4. iiboharz

    aa iiboharz Meme Queen

    Messages:
    700
    Positive Ratings:
    1,025
    The hints (most likely) won't be causing any issues.
     
  5. TheNoobThatWas

    TheNoobThatWas L1: Registered

    Messages:
    17
    Positive Ratings:
    3
    Area portals were fine, the problem was caused by a strange occluder hidden inside the floor. Since it seemed to serve no purpose (it was completely covered by a regular brush), I just removed it entirely. Thanks for the help though, because some of the areaportals were odd too, and I adjusted them.
     
  6. Freyja

    aa Freyja ¯\_(ツ)_/¯

    Messages:
    2,819
    Positive Ratings:
    4,661
    Occluders still work when covered by brushes, in fact that's how they should be used. However it is probably a decompile error.
     
    • Agree Agree x 1