spawning problems

Discussion in 'Mapping Questions & Discussion' started by Ezekel, Apr 6, 2009.

  1. Ezekel

    Ezekel L11: Posh Member

    Messages:
    818
    Positive Ratings:
    244
    in my latest map i had an issue where red was spawning at blu's forward spawn room instead of in their own.
    even with those spawn points disabled + set to blue, and there being red+ enabled spawn points that were not blocked.

    so i deleted every single spawn point, put them in again, making sure i had the right team set to each, and that they were at least 16 units away from anything that might block them.
    now only the 1st spawn point i placed is being used (when i use addbot command, theyall just spawn on top ofeach other)

    there's nothing in the console indicating that the other spawn points are blocked.
    i honestly can't work out why this is happening


    addendum:
    if i put spawn points in blocked positions (i.e. put them in brushes) the console still informs me about this.
    so it's not a case of the spawnpoints not existing on the map either.

    edit:
    even if i disable all spawnpoints, all player still spawn at that spawn point, regardlessof the fact that there is no enabled spawn points anywhere on the map (and they should be spawning at 0,0,0 instead)
     
    Last edited: Apr 6, 2009
  2. Ezekel

    Ezekel L11: Posh Member

    Messages:
    818
    Positive Ratings:
    244
    i really hope someone can offer a suggestion here.
    i've put a lot of work into this, and i don't want to have to scrap it
     
  3. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    Map type? Do you have any t_c_p_round in your map? If you do, spawnpoints MUST be linked to rounds. If you only have one round, you do not need a t_c_p_round.
     
  4. kwagner

    kwagner L2: Junior Member

    Messages:
    92
    Positive Ratings:
    6
    (Note: I'm really new at mapping, so take the following with a big ole grain of doubt filled salt.)

    Are the spawn points WELL clear of the ground? I think I had this same problem when I had the feet of the spawns right on the ground. No matter what I did, I always spawned on the first spot. But when I raised all the spawns a couple units off the floor the problem cleared up.

    I think the problem is that TF2 doesn't want to risk spawning anyone inside a brush, and if the spawn is 'on' the floor, that's too close for TF2. However, it's gotta spawn you someplace, so it defaults to the first point in some internal list.

    The same seemed true regarding having the spawn too close to a wall, ceiling, or even other spawnpoints. They need space to work right.
     
  5. BagOfChips

    BagOfChips L5: Dapper Member

    Messages:
    227
    Positive Ratings:
    11
    ^ I had the same issue. I realized my forward spawn gordons' feet touched a brush.