Spawn problem

Discussion in 'Mapping Questions & Discussion' started by ics, Mar 22, 2012.

  1. ics

    aa ics http://ics-base.net

    Messages:
    696
    Positive Ratings:
    423
    I have 3 blu spawns, 2 forward and the main one. The forward spawnpoints are disabled, the main one is enabled when the map starts. However, when i load the map and for the first time i select a team, then for the first time, class, i always end up to the 2nd forward spawn. If i change class, i end up to the first spawn as i should have been at the first place.

    Once the setup is over, if i die, i end up in the 1st spawn as i should be ending up too. The forward spawns also work ok. Once second cap is capped in the payload, 1st forward spawn activates, 1st one is disabled. Everything works after this as it should, just that on every map load, i end up to the 2nd forward spawn instead of the 1st main base. Any idea how i could fix this? As far as i can tell, everything is setup correctly. I even compared the setup to badwater and barnblitz, they seem to have same properties in all entities and still i have this problem.
     
  2. Wander

    Wander L3: Member

    Messages:
    148
    Positive Ratings:
    42
    Are you sure you are disabling both the spawnroom and the spawn location entities? I believe that only disabling the spawn room brush is not enough
     
  3. Tom Hoen

    Tom Hoen L6: Sharp Member

    Messages:
    320
    Positive Ratings:
    245
    Before someone more experienced comes I want to try helping.

    It might get fixed if you added Associated Control Point to be the same pathtrack which disables/enables the spawnpoints.
     
  4. ics

    aa ics http://ics-base.net

    Messages:
    696
    Positive Ratings:
    423
    I have info_player_teamspawn on 1st and 2nd forward spawn marked as disabled and i disable the earlier spawn when the spawn changes and enable the next upon point cap. Things work there as they should. However, i'm not disabling the respawn room itself, only the spawns but i tried disabling respawnroom alogn with spawns that too, didn't help. On the valve maps, the spawnroom itself isn't disabled either, only the spawnpoints themselves and the spawnroom isn't tied to any control point either in them.

    The spawns do work, only thing is that like i said, when team is selected and class is changed, you spawn at the 2nd forward spawn instead of blu base. You can change class again to switch back to main blu base but that's really not acceptable.

    On brief moment when you select a class, you can see the main blu spawn area for less than a second and then the view is in the 2nd forward spawn.
     
  5. ics

    aa ics http://ics-base.net

    Messages:
    696
    Positive Ratings:
    423
    It appears i solved the issue. I added into blu base spawnpoints "blue spawn for round" round_a and same for red's first spawn area. It fixed the thing. Thanks for the help anyway.