Source SDK won't select TF2

Discussion in 'Mapping Questions & Discussion' started by Jeremy, Apr 25, 2011.

  1. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    299
    So now apparently my Source SDK suddenly expresses a dislike for Team Fortress 2; I can change the "Current Game" to any other game, but it simply won't let me select TF2. Every time I select it, it automatically switches to Half-Life 2, but I can change the game to Portal, or Counter-Strike: Source, or any other game.

    Now I've tried re-installing the SDK and that's done no good, I've re-installed TF2 to no avail, and refreshing the SDK content and resetting the game configurations to default have done nothing. I'm stuck now. Can anyone suggest a solution?

    NOTE: Problem solved.
     
    Last edited: Apr 25, 2011
  2. REEJ

    REEJ L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    176
    Works for me...
    Dumb question: did you reinstall SDK
     
  3. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    299

    I've also tried deleting clientregistry.blob which resulted in steam going all screwy, unable to start or uninstall so I had to system restore.
     
  4. Wilson

    aa Wilson Burial by Sleep

    Messages:
    1,256
    Positive Ratings:
    938
    I think religious people are behind this because this thread only gives this ad instead anything else:

    [​IMG]
     
  5. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    299
    I may be Christian but I have nothing to do with that, I swear.
     
  6. gamemaster1996

    gamemaster1996 L13: Stunning Member

    Messages:
    1,065
    Positive Ratings:
    134
    Gave me microvolts :huh:
     
  7. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    299
    By the way, I still have problems with the SDK.

    EDIT: As it turns out, I get the same problem when trying to set the game to either of the Half-Life 2 episodes. So it's not just TF2.

    EDIT2:
    C:\Program Files\Steam\steamapps\*username\sourcesdk\bin\orangebox\bin\gameconfig.txt


    Cut & pasted Team Fortress 2 settings to the top of the list, and I am now able to access the TF2 files. Cheer.

    I didn't even have to pray to the heavens.
     
    • Thanks Thanks x 1
    Last edited: Apr 25, 2011