Sounds don't work ingame

Discussion in 'Mapping Questions & Discussion' started by Simulacron, Apr 25, 2016.

  1. Simulacron

    Simulacron L6: Sharp Member

    Messages:
    305
    Positive Ratings:
    174
    For my map pd_ritual I want to make custom voiceline. Today I created new ones,but I have problems getting them ingame. They appear in hammer and I also can select and play them put when I compile (and pack) my map the sounds can't be heard. I also changed the sound to the old voiceline I recorded and this is still working, so the ambient_generic or the logic works perfectly. My new voicelines are all wav files like my old ones. They are also in the same folder so tf2 and hammer should find the file.
     
  2. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,389
    Positive Ratings:
    4,224
    Are you getting any errors in the console?
     
  3. Simulacron

    Simulacron L6: Sharp Member

    Messages:
    305
    Positive Ratings:
    174
    The first time I run the map there was something that had to do with the sounds (and was red like an error), but after I loaded the map again it isn't appearing in the consol anymore
     
  4. Vel0city

    aa Vel0city func_fish

    Messages:
    1,931
    Positive Ratings:
    1,540
    Doesn't TF2 only accept MP3s since Valve converted everything a couple of months back?
     
  5. Simulacron

    Simulacron L6: Sharp Member

    Messages:
    305
    Positive Ratings:
    174
    I will try this now

    Edit: My Programm isn't supporting mp3 :p But wav worked fine a few days ago
     
  6. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,389
    Positive Ratings:
    4,224
    TF2 supports both wavs and mp3s, but it's designed so that wav files loop and mp3 files don't.

    Anyway, check the bit rate of your audio files. If I remember correctly Source only supports a bit rate of 44100.