[Solved] Random black textures, no leaks

Discussion in 'Mapping Questions & Discussion' started by MrFlovi, Feb 25, 2020.

  1. MrFlovi

    MrFlovi L2: Junior Member

    Messages:
    65
    Positive Ratings:
    0
    Howdy people, back at it again with another problemo.

    I have a diagonal wall consisting of a window brush and surrounding brushes.
    Some parts of the surrounding brushes appear with a black texture, not all of them, just a few.

    The thing is, my map has no leaks, I have lighting in my map, and cubemaps have already been built correctly.
    So my question is, what is there left to do?

    I have already tried remaking the brush, changing the textures and removing any nearby props.

    help

    Edit: Compile log in case anyone wants it - https://pastebin.com/gJQVLdh7
     
    Last edited: Feb 25, 2020
  2. Pinsplash

    Pinsplash bad bad bad

    Messages:
    54
    Positive Ratings:
    36
    Try adding lights right next to the faces or lowering the lightmap scale.
     
  3. MrFlovi

    MrFlovi L2: Junior Member

    Messages:
    65
    Positive Ratings:
    0
    I have lowered the lightmap scale and added some lights nearby, but nothing has changed. Any other ideas?
     
  4. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,153
    Positive Ratings:
    789
    Can you post screenshots?
     
  5. MrFlovi

    MrFlovi L2: Junior Member

    Messages:
    65
    Positive Ratings:
    0
    upload_2020-2-26_19-29-16.png upload_2020-2-26_19-45-21.png

    Lightmap scale for this wall is 8 atm.
    Also notice that its not the whole face that is black, just parts of the wall
     
  6. ics

    aa ics http://ics-base.net

    Messages:
    802
    Positive Ratings:
    511
    Alt+p for error dialog.
     
  7. Da Spud Lord

    aa Da Spud Lord Occasionally I make maps

    Messages:
    1,153
    Positive Ratings:
    789
    If you put "mat_fullbright 1" in console, do the textures appear? I assume the answer is yes, but I could be wrong, in which case ignore the below paragraph.

    I've had this issue before, and unfortunately it's a tricky one to get rid of because as far as I can tell, it just happens randomly with no obvious cause. Your best bet is to just fiddle with the brushes (clip tool, func_detail, rearranging things, etc) until you can get rid of the dark faces. This might take quite a bit of experimenting to figure out what works, though.
     
    • Thanks Thanks x 1
  8. MrFlovi

    MrFlovi L2: Junior Member

    Messages:
    65
    Positive Ratings:
    0
    Yes, the textures do appear with mat_fullbright 1 on. Thanks for the tips so far people I'll continue problem solving tomorrow.

    Edit: Problem solving done, I fixed the black parts by making the wall a func_detail. Idk if it is the most optimal solution, but if it works, it works.
     
    Last edited: Feb 27, 2020