[Solved] payload map crashing on load

Discussion in 'Mapping Questions & Discussion' started by Kill_the_Bug, May 16, 2017.

  1. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,472
    Positive Ratings:
    237
    Hi guys,

    Map is crashing on load, have determined that it's got something to do with the game logic, everything else seems to be working right.

    Any ideas? I usually have no issues with the game logic for payload maps.
     
  2. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,005
    Positive Ratings:
    1,157
    A loop in the path_tracks, perhaps? Although I've only heard of that causing crashes on joining a team, it's probably still worth checking. Also, look for any entities that might be parented to each other. If it's neither of those, see if you can isolate the area with cordons to help you narrow it down.
     
  3. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,472
    Positive Ratings:
    237
    I think that it's only the mspl game entities and their set up, if I leave all others in except those (tcp master, train watcher, tcp) then map doesn't crash. I don't know if this has anything esle to do with it but when I changed the tcp master hud style from default to payload style the map didn't crash, I didn't get a HUD in game either but I can't connect the dots...
     
  4. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,472
    Positive Ratings:
    237
  5. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,472
    Positive Ratings:
    237
    I don't get it - using cordon box - all 3 stages work independantly, when I put them all together in one compile map crashes.
     
  6. B!scuit

    B!scuit L3: Member

    Messages:
    107
    Positive Ratings:
    108
    Your map looks pretty insane, it wouldn't surprise me if you're pushing some entity limits.
    But definitely sounds like a game logic problem if individual stages work.

    Looking at the .vmf I can see you have two identical team_control_point entities.
    Both have an index of 0 and have the display name "The Waterfall Bridge" (you have 4 points called this).
    They're also unnamed so they can't be in any your round entities in the "control points in this round" field.
    This also means they can't appear on the train_watcher HUD either.
    Coordinates for the two control points are: 252 2606 102 and -655 3251 102

    "The Lake Cave Stage" control point also has no name or unique index.
    Coordinates for that point: 436 -1873 101

    A lot of the blockbullets brushes you should definitely be deleted, it's destroying your vvis.
    You don't need to playerclip blockbullets either, blockbullets stops everything.
    But do use blockbullets2 instead of plain old blockbullets, better for optimisation.

    Still, I do like the look of your map (I'd love to try it out once it's working) and I hope I helped you fix it!
    Also your entire map is func_detailed. all of it. why.

    [EDIT:] 91.4% on the entity limit! duuuude, too much!
    Get rid of func_details and playerclipped blockbullets
    I'm simultaneously impressed and terrified
     
    • Funny Funny x 2
    Last edited: May 18, 2017
  7. B!scuit

    B!scuit L3: Member

    Messages:
    107
    Positive Ratings:
    108
    Replace all your blockbullets textures with blockbullets2 (use the replace button)
    Delete all playerclip brushes that are in the same space as blockbullets

    Just un-func_detail every brush that has a side more that 16Hu thick that isn't at a crazy angle

    Honestly man this map is performance hell but I do genuine want to help you fix it

    [EDIT:]
    Too many crates and barrels and too much detail is some places
    Delete a bunch of props and do what you can to get your entity count down
    The answer was in the compile log all along.
     
    Last edited: May 18, 2017
  8. B!scuit

    B!scuit L3: Member

    Messages:
    107
    Positive Ratings:
    108
    I ran a fast compile with -condebug in game options (advanced compile).
    This is what I have found:

    You have more than 8 control points.
    This breaks the Source Engine.
    Please do not break the Source Engine.
    That was the actual problem but please fix all the other things I mentioned.

    Here is the abridged list of errors:
    ---- Host_NewGame ----
    Network: IP 10.1.1.247, mode MP, dedicated No, ports 27015 SV / 27005 CL
    Spawn Server: pl_goldheist_canyon_final_v4
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/wooden_barrier01.mdl)
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/wooden_barrier01.mdl)
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/wooden_barrier01.mdl)
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/wooden_barrier01.mdl)
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/wooden_barrier01.mdl)
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/wooden_barrier01.mdl)
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/wooden_barrier01.mdl)
    SOLID_VPHYSICS static prop with no vphysics model! (models/props_mining/watertower002.mdl)
    Failed to load models/freak_fortress_2/santa_claus/santa_claus.mdl!
    Failed to load models/goldheistmodel/goldcart_empty.mdl!
    ERROR!: Can't create physics object for models/goldheistmodel/goldcart_empty.mdl
    ERROR!: Can't create physics object for models/goldheistmodel/goldcart_empty.mdl
    Attempted to create unknown entity type item_healthkit!
    NULL Ent in UTIL_PrecacheOther
    Failed to load models/goldheistmodel/goldcart_full.mdl!
    Failed to load models/goldheistmodel/dumptruck.mdl!
    Spawnpoint at (-4283.05 722.16 89.00) is not clear.
    Spawnpoint at (3746.10 -2054.00 466.00) is not clear.
    Spawnpoint at (-4325.47 767.42 89.00) is not clear.
    Bogus constraint red_ride_constraint (attaches red_ride to ENTITY NOT FOUND:red_ride_model)
    Bogus constraint blue_ride_constraint (attaches blue_ride to ENTITY NOT FOUND:blue_ride_model)
    Constraint (mspl_constraint) attached to two shadow objects (mspl_train and mspl_cart)!!!
    Spawnpoint at (861.00 598.00 438.01) is not clear.
    Spawnpoint at (936.00 601.00 438.01) is not clear.
    Spawnpoint at (-258.55 412.02 617.01) is not clear.
    Spawnpoint at (-316.55 415.24 617.01) is not clear.
    !!!!
    Multiple control points with the same index, duplicates ignored
    !!!!
    !!!!
    Multiple control points with the same index, duplicates ignored
    !!!!
    !!!!
    Multiple control points with the same index, duplicates ignored
    !!!!
    !!!!
    Multiple control points with the same index, duplicates ignored
    !!!!
    Too many control points! Max is 8
     
  9. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,472
    Positive Ratings:
    237
    thanks thanks thanks - I'll get to work on the fixes - version 3 works well with 32 players but with your help version 4 will be even better!
     
  10. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,472
    Positive Ratings:
    237
    Thanks B!scuit - map working
     
    • Thanks Thanks x 1