[SOLVED]Multiple issues, but the compiler is only saying there's one entity leak?

Discussion in 'Mapping Questions & Discussion' started by cow tools, Sep 6, 2019.

  1. cow tools

    cow tools L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    I'm working on my first (source, I'm rather experienced in doom) mapping project, and am having a series of rather large errors.
    In order of severity:
    1. When I compile, entire swathes of brushes will simply not be compiled, but will continue to exist in hammer, but not in the map. (Radius Culling is OFF.)
    2. I continue to get leaks straight through solid geometry, i.e. a info_player_teamspawn leaking straight down through the brush it is hovering over.
    3. I can't get water to work. It simply appears as a hall-of-mirrors style error box without water properties, although I've followed the directions to make tf2 water exactly from the valve developer wiki.
    I can provide my most recent compile log if needed (I can't figure out how to insert it on here, I'm new to the forum)
     
    Last edited: Sep 6, 2019
  2. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    1,119
    Positive Ratings:
    763
    Can you post your compile log, please?

    Are you sure the brush is not part of an entity? (Make sure you have "Groups" or "Objects" selected in the top-right corner when you check, otherwise brushes that are part of an entity may not appear to be part of one.)
     
    • Like Like x 1
  3. cow tools

    cow tools L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    It was, uh, all caused by 3 tiny leaks I couldn't find until i shuffled entities around.