[SOLVED] map brightness help

Discussion in 'Mapping Questions & Discussion' started by Donatello, Feb 27, 2017.

  1. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    [​IMG]
    This map is way too bright.

    I want to have a dark forest map, but I have no idea how to make it darker (tried turning down light_environment brightness settings but that didn't do the job well..)
     
  2. Micnax

    aa Micnax I maek map

    Messages:
    2,065
    Positive Ratings:
    1,522
    It appears to be completely fullbright, so there's actually no lighting at all (note no shadows).

    This is either due to a leak, or you ran a previous map that was fullbright too. The first can be fixing the leak in your map (check your compile log for a *** leaked! *** line) and the second can be done by entering the console in-game and typing mat_fullbright 0
     
  3. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    I have a light entity placed in the map.
    and my compile log doesn't show any leak.
     
  4. Micnax

    aa Micnax I maek map

    Messages:
    2,065
    Positive Ratings:
    1,522
    No, but having a leak negates your light_environment because VRAD can't bounce the light properly, resulting in either harsh lighting or no light at all (fullbright)
     
  5. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    Sorry, I edited my post while you were responding to the old one, please read the updated one.
     
  6. Gangstahwezel

    Gangstahwezel L1: Registered

    Messages:
    36
    Positive Ratings:
    20
    Perhaps you compiled your map with only HDR lighting, and have your game settings set to LDR lighting. You either need to compile LDR or both.
     
  7. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    It appears that HDR was still on, did a default compile w/o HDR but map still turns out brighter then wanted:
    [​IMG]
    anymore suggestions?
     
  8. iiboharz

    aa iiboharz Meme Queen

    Messages:
    728
    Positive Ratings:
    1,061
    Post your vmf.
     
  9. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
     

    Attached Files:

    • test.vmf
      File size:
      634.1 KB
      Views:
      30
  10. iiboharz

    aa iiboharz Meme Queen

    Messages:
    728
    Positive Ratings:
    1,061
    You absolutely have a leak, get that info_observer_point out of the void :v

    You also have two light_environment entities.
     
  11. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    I never thought that would count as a leak :eek:

    I also deleted the second sneaky hidden light_environment and the map still looks the same.

    How could I make the map darker? (without making it too dark)
     
  12. turtleboy666

    aa turtleboy666

    Messages:
    66
    Positive Ratings:
    40
    In the future try using the Interlopers Log Checker to easily find leaks.

    As for making it darker, lowering the fourth value of the Brightness of the light_environment should help.
     
  13. Donatello

    Donatello L1: Registered

    Messages:
    46
    Positive Ratings:
    2
    solved, thanks for all the help.