So, What Do I Even CALL A Problem Like This?

Discussion in 'Mapping Questions & Discussion' started by 2Wings, Jul 21, 2015.

  1. 2Wings

    2Wings L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    --------------------------------------------------------------------------------------------------------------------------------------------------------------
    IMPORTANT NOTE:
    This problem has been FIXED by me increasing the servers Max-Player count to 2 (of all things).

    NOT-AS-IMPORTANT NOTE:
    The resupply rooms are still not fixed, as I believe they were not caused by the primary problem, but another (I.E. I'm an idiot).
    I already have my suspicions...
    --------------------------------------------------------------------------------------------------------------------------------------------------------------

    The period of events leading up to the "problem":
    (I'm posting EVERYTHING just in case any of it is helpful, you'll see why...)

    So, I've recently started using Hammer to create a map for fun. I watched Crash's videos on how to use Hammer, but the problem was, my map was a C.P. map, and at the time I am typing this, he unfortunately still hasn't covered that gamemode yet.

    'Oh well, I guess I'll just have to figure things out myself.' I thought to myself.
    And I did.

    I used the gamemode library that came with the resource pack Crash recommended, and the TF2 Developer Wiki (which wasn't nearly as helpful). As I built my map, I tested it twice. Once when I was trying to get a feel for the first room I created, which would later house one of the five points, and a second time simply to test a series of rectangular spiral staircases I created (which was somehow more of a pain than the rest of the map, even up to now).

    Then something happened.
    I remember opening up Hammer one day, to work on the room to hold the next point before mid, and doing exactly that... until I saw my spawnroom. The models to represent the respawn locations had switched from Engineer models (courtesy of the resource pack) to giant error signs, the kind you would find in Gmod if you were missing the required files for a prop model.

    'Okay, I guess I'll just have to reinstall the resource pack...'
    And I did.

    From then on, everything seemed to work perfectly, until I tried testing the map again.
    By then, I'd finished the second point room, and placed both points in, but when I ran the compiler, and looked over the results, I got my first error. Well, first TWO...

    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!

    Yes, those are two identical errors. Ironically, however, by looking up what those errors meant, I actually avoided finding out what those errors ACTUALLY meant. I assumed that they were, as they said, two skybox textures compiled with the wrong size texture. Oh boy, was I "wrong"... I pasted my compile log into the Interlopers Error Checker, and it spat back:

    "You have entered a skybox texture which doesn't seem to be valid. Make sure you don't specify the last three letter (_UP, _DN, etc) of any skybox texture you use."

    Thing was, I had kept track of every single texture I'd ever used in my map up to that point, and as far as I knew, none of them were skybox textures. But I didn't know much. So, when I searched for a good hour and came up empty handed, I was fairly confident that I had no textures on my map considered "Skybox Textures". Now, I don't remember the exact order in which these events took place, so...

    -I found exactly which textures were skewed:
    #1: skybox/sky_tf2_04_hdrdn (Tweedledee)
    #2: skybox/sky_tf2_04dn (Tweedledum)

    Apparently, my first assumption was right, the other textures in this "04" category have size in pixels at 512x512 and 512x256, while these two had a whopping 1x1... Just wait, it gets better...

    -I used a replacement tool to determine that, no, I did not have any instances of either of those two textures on my map.

    -When I started up my map, assuming there was no damage, well, here's the fun part...
    There was no damage to the map itself, just my ability to use it. -______-

    Effects Involved:
    My game saying that the server I was on couldn't connect to the item server...
    Not being able to use my loadouts...
    Still being able to see my loadouts in the loadout menu(?)
    Instant weapon switching...
    Everything in two of the three spawnrooms I created being invisible...
    The resupply cabinets inside them still working despite being invisible...
    The spawn doors inside them NOT working despite being invisible...
    The distinct ability to lag through walls, float in middair, and still get stuck ONTOP of floors...
    The distinct inability to do anything else...
    Noclip not allowing me to move vertically...
    My FPS increasing from 60-100 to 300-400(?)
    All caused by two SKYBOX TEXTURES that are NOT IN MY MAP............

    Let me just Emphisize one FAIRLY important fact... THIS IS NOT A JOKE... -____________-

    My actual compile log:

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.vmf"

    Valve Software - vbsp.exe (Jul 2 2015)
    2 threads
    materialPath: C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Processing areas...done (0)
    Building Faces...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (0)
    writing C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.prt...Building visibility clusters...
    done (1)
    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!
    Finding displacement neighbors...
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (0) (317490 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Compacting texture/material tables...
    Reduced 480 texinfos to 261
    Reduced 8 texdatas to 8 (199 bytes to 199)
    Writing C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.bsp
    1 second elapsed

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" -fast "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo"

    Valve Software - vvis.exe (Jul 2 2015)
    fastvis = true
    2 threads
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.bsp
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.prt
    519 portalclusters
    1368 numportals
    BasePortalVis: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Optimized: 5725 visible clusters (4.47%)
    Total clusters visible: 128106
    Average clusters visible: 246
    Building PAS...
    Average clusters audible: 375
    visdatasize:64231 compressed from 74736
    writing c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.bsp
    0 seconds elapsed

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" -noextra "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo"

    Valve Software - vrad.exe SSE (Jul 2 2015)

    Valve Radiosity Simulator
    2 threads
    [Reading texlights from 'lights.rad']
    [39 texlights parsed from 'lights.rad']

    Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.bsp
    Setting up ray-trace acceleration structure... Done (0.39 seconds)
    2560 faces
    266528 square feet [38380128.00 square inches]
    0 Displacements
    0 Square Feet [0.00 Square Inches]
    2560 patches before subdivision
    37862 patches after subdivision
    0 direct lights
    BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (0)
    BuildVisLeafs: 0...1...2...3...4...5...6...7...8...9...10 (10)
    transfers 4777301, max 647
    transfer lists: 36.4 megs
    GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Bounce #1 added RGB(0, 0, 0)
    Build Patch/Sample Hash Table(s).....Done<0.0186 sec>
    FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (6)
    FinalLightFace Done
    0 of 0 (0% of) surface lights went in leaf ambient cubes.
    ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (4)
    Writing leaf ambient...done
    Ready to Finish

    Object names Objects/Maxobjs Memory / Maxmem Fullness
    ------------ --------------- --------------- --------
    models 25/1024 1200/49152 ( 2.4%)
    brushes 957/8192 11484/98304 (11.7%)
    brushsides 6153/65536 49224/524288 ( 9.4%)
    planes 854/65536 17080/1310720 ( 1.3%)
    vertexes 4207/65536 50484/786432 ( 6.4%)
    nodes 1287/65536 41184/2097152 ( 2.0%)
    texinfos 261/12288 18792/884736 ( 2.1%)
    texdata 8/2048 256/65536 ( 0.4%)
    dispinfos 0/0 0/0 ( 0.0%)
    disp_verts 0/0 0/0 ( 0.0%)
    disp_tris 0/0 0/0 ( 0.0%)
    disp_lmsamples 0/0 0/0 ( 0.0%)
    faces 2560/65536 143360/3670016 ( 3.9%)
    hdr faces 0/65536 0/3670016 ( 0.0%)
    origfaces 1736/65536 97216/3670016 ( 2.6%)
    leaves 1313/65536 42016/2097152 ( 2.0%)
    leaffaces 2792/65536 5584/131072 ( 4.3%)
    leafbrushes 1632/65536 3264/131072 ( 2.5%)
    areas 2/256 16/2048 ( 0.8%)
    surfedges 19018/512000 76072/2048000 ( 3.7%)
    edges 11159/256000 44636/1024000 ( 4.4%)
    LDR worldlights 0/8192 0/720896 ( 0.0%)
    HDR worldlights 0/8192 0/720896 ( 0.0%)
    leafwaterdata 0/32768 0/393216 ( 0.0%)
    waterstrips 244/32768 2440/327680 ( 0.7%)
    waterverts 0/65536 0/786432 ( 0.0%)
    waterindices 4746/65536 9492/131072 ( 7.2%)
    cubemapsamples 0/1024 0/16384 ( 0.0%)
    overlays 0/512 0/180224 ( 0.0%)
    LDR lightdata [variable] 711140/0 ( 0.0%)
    HDR lightdata [variable] 0/0 ( 0.0%)
    visdata [variable] 64231/16777216 ( 0.4%)
    entdata [variable] 36425/393216 ( 9.3%)
    LDR ambient table 1313/65536 5252/262144 ( 2.0%)
    HDR ambient table 1313/65536 5252/262144 ( 2.0%)
    LDR leaf ambient 663/65536 18564/1835008 ( 1.0%)
    HDR leaf ambient 1313/65536 36764/1835008 ( 2.0%)
    occluders 0/0 0/0 ( 0.0%)
    occluder polygons 0/0 0/0 ( 0.0%)
    occluder vert ind 0/0 0/0 ( 0.0%)
    detail props [variable] 1/12 ( 8.3%)
    static props [variable] 1/12 ( 8.3%)
    pakfile [variable] 54/0 ( 0.0%)
    physics [variable] 317490/4194304 ( 7.6%)
    physics terrain [variable] 2/1048576 ( 0.0%)

    Level flags = 0

    Total triangle count: 7034
    Writing c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.bsp
    20 seconds elapsed

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\cp_aperture_techdemo.bsp" "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf\maps\cp_aperture_techdemo.bsp"
     
    Last edited: Jul 29, 2015
  2. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,395
    Positive Ratings:
    4,248
    Actually, these errors...

    ... can be safely ignored. They happen with every TF2 skybox, and as far as I know, all it means is it'll be up to you to build the cube maps yourself (which is a very simple process anyway).

    It's been around pretty much since the start and was never fixed, most likely because Valve noticed it and thought "well it's not breaking anything so whatevs"
     
    • Thanks Thanks x 1
    Last edited: Jul 21, 2015
  3. henke37

    aa henke37

    Messages:
    1,945
    Positive Ratings:
    461
    Also, the skybox is set in the map properties. It's not placed on any brushes.
     
  4. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,377
    Does Interlopers' compile log checker really still claim that error means something? Somebody should contact them and tell them to fix that already.
     
  5. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,496
    The error checker is for Source in general, and it means something in other Source games. It's just TF2 that has the error because the skybox textures are a certain shape or something.
     
  6. henke37

    aa henke37

    Messages:
    1,945
    Positive Ratings:
    461
    It's because the skyboxes have bottoms with 1x1 resolution. Because of reasons, vbsp can't build default cubemaps when the textures don't all have the same resolution.
     
    • Thanks Thanks x 1
  7. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,496
    I guess if you need a guide for building cubemaps this should work. For alpha maps, I'd say just place 1 cubemap (unless you need more for water or lots of shiny surfaces) so you aren't moving them all around if you adjust your layout. You can place more in later beta or RC stages.

    Thanks for posting so much info regarding your issue, by the way. Even though your error was very simple, I appreciated it. Although next time please put your compile log on pastebin or something similar.
     
    • Thanks Thanks x 1