Skybox / Water Error

Discussion in 'Mapping Questions & Discussion' started by timberghost_paintball, Jan 27, 2008.

  1. timberghost_paintball

    timberghost_paintball L2: Junior Member

    Messages:
    77
    Positive Ratings:
    106
    I think a few people are having this problem but I'll include pics of my specific situation and the details of what I'm doing and have tryed.

    Here are pics of a small but important pool in my map
    [​IMG]
    the top left and bottom right are from above. the visual distortion changes as you move. the middle two are inside the water looking up and down.

    there are no leaks as far as I can tell

    the water is no draw with a water2fort texture (plain 1 no dx 8)

    there is a cubemap connected 2 it

    the sky is not visible from the water area

    the sky texture gives a error or compile (the size/ flags error that lots of people are getting) so there is no sky cubemap

    the texture is gravel but none work including hydro

    This is one of the last things I have to deal with to finish this map so if anyone can help I would be really grateful the water is an important element and I would hate to cut it.

    btw has anyone gotten water to work at all and if so under what conditions.
     
  2. Sacrifist

    Sacrifist L3: Member

    Messages:
    130
    Positive Ratings:
    7
    Hydro's sky does work properly. Try using it and if your water is still that way, try changing your water to well's water using Hydro's sky and see what happens. Also, make 100% certain that you dont have a leak somewhere. It will tell you in the compiling window if there is a leak somewhere.
     
  3. Snipergen

    Snipergen L13: Stunning Member

    Messages:
    1,053
    Positive Ratings:
    150
    I think too that there is a leak. :) Help us out with your vmf and compile log to help you out :)
     
  4. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    My vote is on a leak, or you haven't run VVIS (water only works once you run VVIS)
     
  5. timberghost_paintball

    timberghost_paintball L2: Junior Member

    Messages:
    77
    Positive Ratings:
    106
    weirder still

    well I switched to hydro and no difference I also checked for leaks and I found something interesting...

    the first time it said that 1 prop was leaking this is a large rock prop and it was safely in the middle of the map were I could not possibly figure out where it could be leaking so I just deleted it for a test

    after that test the problem continued to occur so I checked again and this time it said 1 light was leaking and again it was safely in the map (I hadn't touched it since the last time were only the prop leaked) so I deleted it too

    the 3rd time it still didn't work and again it picked another prop which was safely in the map.

    note:there also is a portal error in the report that doesn't make sense cause I haven't gotten to including portals yet.

    also when cubemaps are built the water clearly doesn't appear and the walls around the water are black (but they aren't leaking or func_detail or anything)
     
  6. Snipergen

    Snipergen L13: Stunning Member

    Messages:
    1,053
    Positive Ratings:
    150
    Uhm, I think you build your map on a dirty way or something anyway, I think your vmf is corrupt as hell. Show the vmf please.
     
  7. Narkissus

    Narkissus L5: Dapper Member

    Messages:
    228
    Positive Ratings:
    9
    If it says a prop or anything is leaking and its clearly in the map that still means its a leak
    thats just what the red line from loading a pointfile will be originated from, load the pointfiles
    and look for where the leak is, thats all i can think of.
     
  8. timberghost_paintball

    timberghost_paintball L2: Junior Member

    Messages:
    77
    Positive Ratings:
    106
    MEGA Thanks guys, it wasn't the props they were just the pointfile spot there were 2 really small 1 point leaks

    everything looks great with hydro I'm gonna try it with gravel now cause it matches the lighting much better.

    Thanks again to all