Skybox problem

Discussion in 'Mapping Questions & Discussion' started by Pocok, Aug 21, 2008.

  1. Pocok

    Pocok L1: Registered

    Messages:
    30
    Positive Ratings:
    0
    Hi! I'm making an Alpine style map, and when I added the skybox, and ran the game somehow it didnt work. On the side of my map I saw my map from outside:
    [​IMG]
    [​IMG]
    [​IMG]

    In the complie it told that there is a problem with the skybox, with the size, but i dont know how shoul i fix it:

    Code:
    *** Error: Skybox vtf files for skybox/sky_trainyard_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_trainyard_01 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_trainyard_01 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_trainyard_01 to build the default cubemap!
    How could i fix it?

    Thanks
    Pocok
     
  2. Laz

    Laz L7: Fancy Member

    Messages:
    461
    Positive Ratings:
    34
    those compile errors are normal :)

    what you want to do, is move the sky_camera out of your map and into your 3d skybox.

    how I do it:
    create the sky camera on my origin(0,0,0) and add it to a skybox visgroup.
    Then I hide all the skybrushes, and add on my 3d skybox to my level itself(for reference), while adding all that I add to the 3d skybox visgroup.

    then I select the entire 3d skybox visgroup, and move it next to my map,
    I make sure my texture locks are on, then scale it down to 1/16th.
    Add a skybox around that.

    make sure you unhide all before you compile.


    what happens to you here is that your sky camera is still inside your normal level, so it takes the normal level as a skybox for itself.

    If it is just a normal 2d skybox you want, delete the sky camera entity.
     
  3. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,741
    Also make sure you compiled vis properly and that there are no leaks, both a lack of vis and leaks will cause this to happen.
     
    • Thanks Thanks x 1
  4. Tom EA

    Tom EA L1: Registered

    Messages:
    1
    Positive Ratings:
    0
    I had the same problem but only when i compiled with no VIS information. With Fast or Normal on VIS there was no problem.