Shadows looking really ugly on func_details

Discussion in 'Mapping Questions & Discussion' started by Hipster_Duck, Jan 19, 2016.

  1. Hipster_Duck

    Hipster_Duck L2: Junior Member

    Messages:
    95
    Positive Ratings:
    75
    So, I've recently started Hammer and up until this point (Thanks to UEAKCrash' tutorials) its gone quite smooth, and problem free. But, when I decided to try an optimize my map a bit by func_deatail-ing some roofs, the shadows started getting really, really ugly.
    2016-01-19_00001.jpg
    So, if anyone knows what's going on, help would be greatly appreciated - Hipster_Duck.
     
  2. Anreol

    Anreol L6: Sharp Member

    Messages:
    262
    Positive Ratings:
    273
    • Useful Useful x 1
  3. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    Doesn't look like a leak, looks like one of two things:

    Either - a prop collision mesh (or if the prop doesn't have one, the bounding box) is intersecting the roof and blocking light. The solution is to ignore it until you're ready to do a final compile and then use this guide

    Or - it's a VRAD bug which as far as I know can't be fixed, only mitigated by moving the map slightly.

    By looking at it, I think it's the latter.
     
    • Useful Useful x 1
  4. Hipster_Duck

    Hipster_Duck L2: Junior Member

    Messages:
    95
    Positive Ratings:
    75
    Darren, just checked that, the map is completely sealed. YM, I think you're right, its my props for lights, there all in the roof, but I presume it's like PL track and when I do a final compile the ugly shadows will go away. Thanks both of you for your help and quick responses.
     
  5. ics

    aa ics http://ics-base.net

    Messages:
    654
    Positive Ratings:
    410
    Are the shadows there if you dont func_detail them? How about what compile options do you use? Fast or normal?

    Edit: nvm, we posted at the same time.
     
  6. Hipster_Duck

    Hipster_Duck L2: Junior Member

    Messages:
    95
    Positive Ratings:
    75
    ics, Yea I just checked, the shadows were there before I func_detailed them, I only just noticed them after I was looking at my roof after I func_detailed them, and my compile options are normal, normal, normal.
     
  7. Vel0city

    aa Vel0city mission somewhat possible

    Messages:
    1,880
    Positive Ratings:
    1,484
    It's a common Source engine bug to display all kinds of weird lighting, ranging from random black spots to actually making up colors in really dark spots (a couple of TF2 maps actually have this very thing).

    Just to be sure, run VRAD on pretty much max with static prop lighting and prop shadows and all that and see if it still happens. If it does, do what YM suggested. Otherwise, well, I think it comes down to just accepting it the way it is. It's Source.

    By the way, that's one sw$g duck you have there as avatar.
     
  8. Hipster_Duck

    Hipster_Duck L2: Junior Member

    Messages:
    95
    Positive Ratings:
    75
    Thanks, I made the avatar myself in Blender!