Serious error

Discussion in 'Off Topic' started by Kraken, Feb 13, 2015.

  1. Kraken

    Kraken Few more zeros and ones for the site to proccess

    Messages:
    434
    Positive Ratings:
    115
    Getting a error from opening tf2.
    Crashing when trying to load game after credits.
    Missing section 'OBJ_DISPENSER' from scripts/objects.txt.
    What do I do.
     
  2. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,003
    Positive Ratings:
    1,155
    Have you tried verifying your game cache?
     
  3. Kraken

    Kraken Few more zeros and ones for the site to proccess

    Messages:
    434
    Positive Ratings:
    115
    What does verifying means?
     
  4. Kraken

    Kraken Few more zeros and ones for the site to proccess

    Messages:
    434
    Positive Ratings:
    115
    No doesn't work.
     
  5. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    937
    Positive Ratings:
    905
    Seems like you are missing

    Code:
        OBJ_DISPENSER
        {
            ClassName            obj_dispenser
            StatusName            "#TF_Object_Dispenser"
            BuildTime            20
            MaxObjects            1
            Cost                100
            CostMultiplier        1
            UpgradeCost            200
            UpgradeDuration        1.5
            MaxUpgradeLevel        0
            BuilderWeaponName    "Dispenser"
            BuilderPlacementString    "Place on ground"
            SelectionSlot        5
            SelectionPosition    1
            SapperAttachTime    0.0
            IconActive            obj_dispenser
            IconInactive        obj_dispenser
            IconMenu        hud_menu_dispenser_build
            UseItemInfo        1
            Viewmodel            "models/weapons/c_models/c_toolbox/c_toolbox.mdl"
            Playermodel            "models/weapons/c_models/c_toolbox/c_toolbox.mdl"
            DisplayPriority        3
            HudStatusIcon        "obj_status_dispenser"
            VisibleInWeaponSelection 0
            ExplodeSound        "Building_Dispenser.Explode"
            ExplodeEffect        "ExplosionCore_buildings"
            MetalToDropInGibs    50
            UpgradeSound        "Building_Sentrygun.Built"
            BuildCount        1
            RequiresOwnBuilder    0
        }

    Validating is basicaly the only way to fix this problem. Except if you have mods that don't include this stuff.