security_fence lighting issues

Discussion in 'Mapping Questions & Discussion' started by Lain, Aug 12, 2016.

  1. Lain

    aa Lain Resident wrong opinion holder

    Messages:
    725
    Positive Ratings:
    653
    Using -staticproplighting, -textureshadows, -staticproppolys and still getting ugly lighting like this.

    [​IMG][​IMG]
     
  2. Yrr

    aa Yrr An Actual Deer

    Messages:
    989
    Positive Ratings:
    1,888
    I'd honestly just turn shadows off on them
     
  3. Another Bad Pun

    Server Staff Another Bad Pun learning to fly

    Messages:
    578
    Positive Ratings:
    1,177
    I think you have to specify -proptextureshadows for the fence models somewhere in your own lights.rad file. At least, you used to. It might be fixed by now. Or Valve just broke it again
    I'll add a source to this post if I have time
     
  4. Lain

    aa Lain Resident wrong opinion holder

    Messages:
    725
    Positive Ratings:
    653
    Shadows are off.

    I've seen it done without a rad file before. Might have been CSGO though.
     
  5. iiboharz

    aa iiboharz Meme Queen

    Messages:
    707
    Positive Ratings:
    1,030
    I'm honestly not sure considering I usually compile and their shadows are fine. You shouldn't need a custom lights.rad because the relevant textures are defined in lights.rad by default. What's your exact vrad settings?
     
  6. sevin

    aa sevin

    Messages:
    959
    Positive Ratings:
    661
    Sure you spelled -textureshadows correctly in the compile parameters? Could be as simple as that.
     
    • Agree Agree x 1
  7. Lain

    aa Lain Resident wrong opinion holder

    Messages:
    725
    Positive Ratings:
    653
    Literally copied the string here exactly as it was wrote.

    Edit: rip
    Edit edit: that didn't fix it
     
    Last edited: Aug 12, 2016
  8. Another Bad Pun

    Server Staff Another Bad Pun learning to fly

    Messages:
    578
    Positive Ratings:
    1,177
    Maybe check the model properties and make sure -textureshadows isn't disabled? I think you can do that
     
    Last edited: Aug 12, 2016
  9. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    937
    Positive Ratings:
    905
    The default lights.rad file (located in tf2_misc_dir.vpk) has these models referenced.
    Try copying it into tf/custom/whatever and try again?