1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Request help with a noob problem

Discussion in 'Mapping Questions & Discussion' started by Rock, Jan 27, 2008.

  1. Rock

    Rock L2: Junior Member

    Messages:
    51
    Positive Ratings:
    5
    I'm managed to create two rooms and connect them with a tunnel. Add lights for practice and a player start point (not on the floor). When I compile (F9) and go to the Valve test server, after selecting my player, the screen freezes and I see a black opaque image of my player's weapon on the frozen selection screen.

    I had managed to get into my room a couple of tries ago but this has me stumped.

    [​IMG]
     
  2. Sean of the Dead

    Sean of the Dead L3: Member

    Messages:
    123
    Positive Ratings:
    4
    send me the .vmf or post it here and ill take a look at it :D
     
  3. dirtyminuth

    dirtyminuth L5: Dapper Member

    Messages:
    221
    Positive Ratings:
    14
    If you're running TF2 through Hammer, don't. Instead, let Hammer compile and copy the file, then run TF2 as you might normally. There are many stability / performance issues involved with running TF2 through Hammer.

    That might not be the root issue, but it will definitely allow us to narrow down the problem you're having.
     
  4. Rock

    Rock L2: Junior Member

    Messages:
    51
    Positive Ratings:
    5
    Okay, I opened the map through the "Create Server" function and got the same result. Sean, I'm going to e-mail the .vmf file to you because I don't know how to post it here (yes, it's true - I am a noob).

    Thanks for the tips.

    [​IMG]
     
  5. DJive

    aa DJive Cake or Death?

    Messages:
    1,466
    Positive Ratings:
    740
    Last edited: Jan 27, 2008
  6. Sean of the Dead

    Sean of the Dead L3: Member

    Messages:
    123
    Positive Ratings:
    4
    what u sent me is the .bsp, but i can decompile it and check it out :p
     
  7. Sean of the Dead

    Sean of the Dead L3: Member

    Messages:
    123
    Positive Ratings:
    4
    http://www.mediafire.com/?fmj7adyzy3h

    what u had was was that u had a single player spawn set up, and u dodnt have a func_respawnroom. u need to make sure it is an info_player_teamspawn, and that u put a func_respawnroom around it ;)
     
  8. DrHaphazard

    DrHaphazard L5: Dapper Member

    Messages:
    249
    Positive Ratings:
    12
    Yeah you definetly need info_player_teamspawn. Youll notice if you go into the Properties menu of info_player_teamspawn that you can set which team can use that spawn point (or allow either team to do so.)

    As to the func_respawnroom, I am certain you dont need this because in all my test maps i never make them. However, it is good practice to do so, and definetly a must for any non-test maps.
     
  9. Rock

    Rock L2: Junior Member

    Messages:
    51
    Positive Ratings:
    5
    First, huge and very large thanks to DJive who took the time to examine my .vmf file and found the problem straight away. When I was trying to create a door, I managed to tie in the func_detail to the whole map and that's a very, very bad thing to do. He also set me up in a skybox and fixed the spawn thingy.

    I had followed a tut on Pixel2Life for the creation of the room and the spawn thingy but next time I'll only take advice from the pros at TF2MAPS.NET.

    [​IMG]
     
  10. Sean of the Dead

    Sean of the Dead L3: Member

    Messages:
    123
    Positive Ratings:
    4
    wtf? no credit to me???
     
  11. Osten

    Osten Guest

    Positive Ratings:
    0
    Credits anyone? No? Okay, i'll just throw these away.
     
  12. Rock

    Rock L2: Junior Member

    Messages:
    51
    Positive Ratings:
    5
    5 Bonus Points for Sean of the Dead for his timely intervention on my behalf. There will be a little something extra in your next paycheck. :D
     
    • Thanks Thanks x 1