Really annoying language problem (Windows/TF2)

Discussion in 'Team Fortress 2 Talk' started by luxatile, Dec 12, 2009.

  1. luxatile

    aa luxatile deer

    Messages:
    2,289
    Positive Ratings:
    1,380
    So. I have a Norwegian keyboard, it's a little different from most others because it needs some keys for Æ, Ø and Å. Therefore, other keys are switched around, and when TF2 suddenly decides my keyboard needs to be English, there's trouble, as the keys I press will no longer correspond to what they output in form of text. For example, my Æ key will output a full stop.

    Now, it would be good if Windows just managed to keep it set to Norwegian at all times, but whenever I play TF2, it seems to randomly switch to English when it feels like it. If I alt+tab I can briefly see an "EN" in the corner before it resets to "NO", so it's definitely Windows, but caused by TF2.

    The obvious solution is to remove English from the list of languages for Windows 7. But guess what. This doesn't remove English after all. What the hell.

    Anything else I can do? Is there a command I can give TF2 or something? This has been pissing me off for too long.
     
  2. Randdalf

    aa Randdalf

    Messages:
    1,054
    Positive Ratings:
    466
    Don't type in Norweigan? :D:D:D
     
  3. Ravidge

    aa Ravidge Grand Vizier

    Messages:
    1,544
    Positive Ratings:
    2,518
    There are hotkeys to change between languages, I think it was shift+alt+mousewheel? Maybe you've just accidentally set TF2/HL2.exe to english and need to switch it back.
     
    • Thanks Thanks x 1
  4. Tinker

    aa Tinker

    Messages:
    672
    Positive Ratings:
    334
    Yeah, it's the annoying hotkeys: Shift + Ctrl, which most people end up clicking together a lot in TF2. Open the chatbox, press Shift+Ctrl again and it should be gone. It's still annoying as hell though.
     
    • Thanks Thanks x 2
  5. Echelon

    Echelon L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    No it's not. I have uninstalled all other languages and only have norwegian in windows. I have also disabled the hotkey thing. The problem is within TF2. The console or chat window often changes to random languages like Japan, Taiwan etc... i don't know how to stop it.