Purple glass, why is it purple

Discussion in 'Mapping Questions & Discussion' started by Explodeyman, Feb 13, 2011.

  1. Explodeyman

    Explodeyman L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    So Ive been making a new map and i remembered that I needed a cubemap so i added one, but after i added it, i noticed In-game that the glass has a purple tint.
    Why is that? Any help?
    [​IMG]
     
    Last edited: Feb 13, 2011
  2. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,692
    When you go in-game, type in console:

    Code:
    mat_specular 0 ; buildcubemaps ; mat_specular 1 ; disconnect ; mat_reloadallmaterials
    The latter two are just if you want to see the reflections without restarting TF2; launching an official map would work as well.
     
  3. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,499
  4. PL-7764

    PL-7764 L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    84
    Don't forget mat_specular 1 after building cubemaps. Otherwise things stay non-reflective.

    Also you do actually need to load another map in between, or restart TF2 (loading another map is easier of course). I've tried just reloading the same map right away, it doesn't reload the materials with the cubemaps and everything. Maybe I did it wrong, but if there's a right way without loading another map I'd like to know it for convenience.
     
  5. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,499
    No, you're right, you do need to load another map in between. I don't think specular matters. Maybe it does. I don't know.
     
  6. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,768
    turning specular off just stops the purple checkers from being recorded in the reflections. Otherwise you get purple checkers in your otherwise working reflections.
     
  7. PL-7764

    PL-7764 L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    84
    But if you don't re-enable it, doesn't it stay off until you put in the command or until you restart TF2 (thus not allowing you to observe your reflections)? That's what I was getting at. It's been so long since I've done the process without resetting it to 1 manually that I don't remember if it does change back to default on map change.
     
  8. Eyce

    Eyce L6: Sharp Member

    Messages:
    370
    Positive Ratings:
    225
    I've always done mat_specular 0 in console with the map up, buildcubemaps follows it, then I disconnect and mat_specular 1. Everything goes fine.
     
  9. Explodeyman

    Explodeyman L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Everything that you all said seems to be working so thanks!
     
  10. The_Ulf

    The_Ulf L6: Sharp Member

    Messages:
    399
    Positive Ratings:
    115
    I've always just done:
    mat_specular 0
    buildcubemaps
    map *MAPNAMEHERE*
    mat_specular 1

    Seems to work correctly...? Don't think you need a full disconnect/load another map.