Purple glass textures/models with and without cubemap

Discussion in 'Mapping Questions & Discussion' started by KernCore, Aug 29, 2009.

  1. KernCore

    KernCore L1: Registered

    Messages:
    7
    Positive Ratings:
    1
    Hi mates!
    I have nearly finished my TF2 map... but since the last compile (I don't really change something), my glass textures have purple reflections...
    So I tried to remove the cubemaps... then the glass isn't purple anymore, but every other model...

    Here a picture of what I mean:

    [​IMG]

    I tried to build cubemap, but then I get an TF2 skybox error...
    (Don't get this error with a HL2 skybox, but still purple textures)
    (I'm playing on DX8 mode, but normally everything works great)
    Can anyone help me to fix this problem :O
     
  2. KarmaPolice

    KarmaPolice L3: Member

    Messages:
    108
    Positive Ratings:
    52
    Make sure you turn off mat_specular before you build the cubemaps.
     
  3. KernCore

    KernCore L1: Registered

    Messages:
    7
    Positive Ratings:
    1
    Ohhh thanks mate!
    I set mat_specular to 0... built the cubemaps... set it to 1 again (purple again), restarted TF2... and it looks great...! :)
    But only with a HL2 skybox (sky_day01_01)... when I take a TF2 one (sky_well_01) I get this error

    How I can fix that?
     
    Last edited: Aug 29, 2009
  4. Xi.Cynx

    aa Xi.Cynx Former Alias: †Blade†

    Messages:
    772
    Positive Ratings:
    721
    That's normal, you just ignore it and everything should still be good. =) If you need to know how to build cubemaps properly here is what you need to do:

    -load the map
    -mat_specular 0
    -buildcubemaps
    -disconnect
    -mat_hdr_level 0
    -map <mapname>
    -buildcubemaps
    -disconnect
    -mat_specular 1
    -mat_hdr_level 2
    -(load different level)map <mapname>
    -(load your map again)map <mapname>


    <<Credits to Youme>>
     
    • Thanks Thanks x 2
    Last edited: Aug 31, 2009
  5. KernCore

    KernCore L1: Registered

    Messages:
    7
    Positive Ratings:
    1
    Thank you... I searched a bit here on the site and I found this steps
    (They are a bit easier)

    and it works.... thank you all :)
     
    Last edited: Aug 29, 2009
  6. KarmaPolice

    KarmaPolice L3: Member

    Messages:
    108
    Positive Ratings:
    52
    You need to do the other steps as well. Different cubemaps are used for different HDR settings, so you need to build both.
     
  7. KernCore

    KernCore L1: Registered

    Messages:
    7
    Positive Ratings:
    1
    Ok... and what he means with "load different level"?
     
  8. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    146
    Load a different map like 2fort then yours again to reset caches. See link in my sig for info.
     
  9. KernCore

    KernCore L1: Registered

    Messages:
    7
    Positive Ratings:
    1
    Ah Ok :p

    BTW... I'm using containers in my map... but they don't really make a shadow (Disable shadows: No)...

    [​IMG]
    [​IMG]

    Is there a way to fix this new problem or do I need to put a blocklight in every single container?
     
    Last edited: Aug 30, 2009
  10. Xi.Cynx

    aa Xi.Cynx Former Alias: †Blade†

    Messages:
    772
    Positive Ratings:
    721
    Hmm... as far as I know you prolly will have to use a block light. But I would just make them 1 unit high and place them "just" under the containers only where you need it to block light and make sure it doesn't touch any of the other containers on the sides as it will block light from even getting to it and thus creating a weird unnatural shadow on it.