Props Disappearing on Map Run

Discussion in 'Mapping Questions & Discussion' started by Midday_Fury, Dec 30, 2015.

  1. Midday_Fury

    Midday_Fury L1: Registered

    Messages:
    13
    Positive Ratings:
    1
    Hello everyone,

    I have an issue that I cannot seem to figure out that I am hoping someone would have the answer to.

    Currently, within my map, I have a table that is littered with food and bottles, and the Medic's Amputator. I have set all of these props to prop_static, because I want them to stay stationary throughout the game.

    My problem is, every time I run the map, all but the bottles vanish into thin air. I'll show you what I mean.

    Within Hammer: https://gyazo.com/c6ed3237216a18363f56f820a022791e

    In Game: https://gyazo.com/816b48ff872581719fedb251c412b964

    Props used:
    models/weapons/c_models/c_amputator/c_amputator.mdl
    models/weapons/c_models/c_sandwich/c_sandwich.mdl
    models/weapons/c_models/c_ham/c_ham.mdl
    models/weapons/c_models/c_bottle/c_bottle_broken.mdl
    models/props_gameplay/bottle001.mdl

    Amputator's Object Properties: (Class Info) (For example)
    https://gyazo.com/28d3ea6bf7ee8bba0a54365157625acf
     
  2. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,372
    Positive Ratings:
    4,174
    The models/weapons props have to be prop_dynamic, since they weren't compiled to be static props.
     
  3. Midday_Fury

    Midday_Fury L1: Registered

    Messages:
    13
    Positive Ratings:
    1
    Oh okay, thanks. Didn't know it was that simple of a fix.