Prop_dynamics Flicker

Discussion in 'Mapping Questions & Discussion' started by RetroNuva10, Jan 7, 2015.

  1. RetroNuva10

    RetroNuva10 L1: Registered

    Messages:
    16
    Positive Ratings:
    1
    I'm making my map, (cp_liftoff) and I ran into a problem. When I make prop_dynamics, certain ones flicker while playtesting when I shoot them. I tried changing them to prop_statics, which fixed half of them, but the rest just disappeared completely! Please help.



    Cheers,
    -Ben.
     
  2. HQDefault

    aa HQDefault ...what

    Messages:
    1,058
    Positive Ratings:
    437
    I have that problem too :/
    I just blew it off as a game bug and kept going.

    It's not anything game breaking. Don't let it halt your progress, just keep going, and when you figure out the problem, then you can fix it.
     
    • Thanks Thanks x 1
  3. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,390
    Positive Ratings:
    4,229
    I've seen this happen in quite a few maps lately. It's probably a Source bug.
     
  4. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    949
    Positive Ratings:
    936
    Always use prop_static if possible. Prop_dynamic is only usefull for things that move.
    Ignore the flickering.
     
    • Thanks Thanks x 1
  5. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    Like tumbolisu already said, always try to use prop_static. If props are disappearing as prop_static then you were using a few props which only work as prop_dynamic.
    In the model browser you can check as which entity the model is avaiable. But almost all the prop you usually place in maps are available as prop_static
     
    • Thanks Thanks x 1
  6. Zed

    aa Zed Certified Most Crunk™

    Messages:
    1,248
    Positive Ratings:
    1,013
    The example that comes to mind is Nucleus. It's hard to look at.
     
  7. iiboharz

    aa iiboharz Meme Queen

    Messages:
    718
    Positive Ratings:
    1,040
    I've seen this happening a bunch on mvm_rottenburg, in particular the barrier that the tanks smash through.
     
  8. RetroNuva10

    RetroNuva10 L1: Registered

    Messages:
    16
    Positive Ratings:
    1
    Wow.. never thought I'd get so many comments in 2 days :O

    Thanks for the help. Yeah, on Nucleus, the "Nucleus" flashes when I shoot it..



    Cheers,
    -Ben.
     
  9. Fantasma

    aa Fantasma

    Messages:
    886
    Positive Ratings:
    981
    Happens on my laptop but not my pc, probs a directx thing who knows.
     
    • Thanks Thanks x 1
  10. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    This hasn't been happening to me, but I wonder if it's related to the bug their Linux ports had early on.