prop_dynamic won't parent to func_door (Fixed!)

Discussion in 'Mapping Questions & Discussion' started by TheAppleJhon, Oct 19, 2015.

  1. TheAppleJhon

    TheAppleJhon L2: Junior Member

    Messages:
    72
    Positive Ratings:
    25
    So i am working on an update for my map Koth Rooftop Plaza!

    I want to add an elevator to the roof, and for a while everything worked correctly. The the props were parenting perfectly and the 2 func_doors opens like they should at the correct time.
    This is how i have set it up:
    the main func_door name 'elevator' moves up when it is set to open, then it waits 10 seconds and resets. When it is fully reset, an output gets triggered that sets it to open again with a 10 seconds delay. The func_door is set to start closed, wich means that it is on the lowest floor.

    There are 2 door_func set to open when the elevator is fully closed or fully open, but i don't think they are relevant.

    now to the problem:

    I want lighting in the elevator that moves with it, so ophviously i want a light_dynamic entity (as I understand you can also use env_textureprojector, but light_dynamic seems to have all the options i need and the other options has way too many restrictions). So i place the light entity and i add an info_target under recommendation and i make the light_dynamic entity point at the target. After that i parent both eneties to the elevator like everything else, and that's where things get's weird.

    The light entity in-game is on the top floor (the roof) completely static. Now you may think it's not recognizing that it's parented, but remember:
    The light has been placed on the bottom floor! The elevator has been set to start at the bottom floor too!

    This means that the only way the light can be on second floor is if it has moved with the elevator. Then it has in some way unlocked itself from the parenting, wich means that it has stayed on the second floor!


    If this is a bit too much for you, i have made this to help you understand:

    [​IMG]

    Hoping someone can figure it out!
     
  2. TheAppleJhon

    TheAppleJhon L2: Junior Member

    Messages:
    72
    Positive Ratings:
    25
    I fixed it! I just set a logic_auto to parent the light when the round gets reset. I think you can also set it to when the map gets spawned, but i think the round option is more safe! Don't know why this happened, but it works now! Hope someone got something out of this, other than me!