prop visibility problem

Discussion in 'Mapping Questions & Discussion' started by Kobolite, Sep 11, 2017.

  1. Kobolite

    Kobolite L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    206
    so timber terror has this problem were on blu side on the left side of the goal if you walk around a bit you will notice that all the props appear. i don't know why it happends or how. i made a video about it so you can see what happends


    View: https://www.youtube.com/watch?v=Cw6GiqiK-6A
     
  2. Vel0city

    aa Vel0city Mission Impossible Spider

    Messages:
    1,866
    Positive Ratings:
    1,463
    Do you have fade distances set? These look like fade distances kicking in only you made them fade waaaaay too soon.
     
    • Agree Agree x 1
    • Respectfully Disagree Respectfully Disagree x 1
  3. ics

    aa ics http://ics-base.net

    Messages:
    651
    Positive Ratings:
    393
    Looks like to me as if your visleafs are tricking you or areaportal with them. Do you have any hint/skip going through areaportal at that area where you move forth and back? If so, remove them and try compiling again. Infact, compile without hint/skip brushes once and see what happens.
     
    • Agree Agree x 1
  4. Lampenpam

    Lampenpam L12: Fabulous Member

    Messages:
    935
    Positive Ratings:
    289
    providing the compile log would be helpful too to see if there arent any other issues
     
    • Agree Agree x 2
  5. Kobolite

    Kobolite L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    206
    i compiled without skip/hint burshes and the same thing happened, all the props just disapear
     
  6. Lampenpam

    Lampenpam L12: Fabulous Member

    Messages:
    935
    Positive Ratings:
    289
    common, give us the log already
     
    • Agree Agree x 1
    Last edited: Sep 11, 2017
  7. MOCOLONI

    MOCOLONI L5: Dapper Member

    Messages:
    221
    Positive Ratings:
    52
    If that's a decompiled version of pass_timbertown, I'm pretty sure it's caused because of misplaced areaportals; it's a common issue when decompiling the map. I may be wrong accusing areaportals but I'd still like to point out their issue on decompiled maps.

    As for the removal of skip/hint brushes, you should go to the VisGroups>Auto, hide everything by un-checking "Auto" and only check either "Hint" or "Skip"; either choice will automatically check both. Lastly, use the mouse in a 2D-view window, mark everything and press Enter to select all these brushes and remove them. Don't use the "Select All" option from "Edit" as it will select everything in your map, even the hidden objects.

    This method ensures the removal of any Skip/Hint textures in the map so you don't miss any. You should also save the Hint-less version of the map with a different filename for tesing purposes.
     
  8. Kobolite

    Kobolite L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    206
    i removed all the area portals in V2 of timber terror since they were bugging so it can't be misplaced area portals
     
  9. Lampenpam

    Lampenpam L12: Fabulous Member

    Messages:
    935
    Positive Ratings:
    289
    compile log plzzz
     
  10. Kobolite

    Kobolite L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    206
  11. Lampenpam

    Lampenpam L12: Fabulous Member

    Messages:
    935
    Positive Ratings:
    289
    Thanks. Well looks like compile machine broke big time.

    This might be a leak caused by your usual leak or area portal leak. Is the point file bringing up anything?

    But there is also this error:

    There might be some brush that gives the compiler a hard time. If the pointfile shows no leak then it's most definitely some corrupt brush. Try compiling parts of your map with :cordonenable::cordonedit: and see in which areas those errors still occur. Also compile with full vvis just to be sure.
    By compiling parts you might be able to hunt down the offending brush.
     
    • Thanks Thanks x 1
  12. Kobolite

    Kobolite L6: Sharp Member

    Messages:
    376
    Positive Ratings:
    206
    i compiled with :cordonenable::cordonedit: and there was a big red box with blue cubes at the 0 0 0 coords
    EDIT: the 0 0 0 coords are somewhere outside the actual map and in the void
     
  13. Yabayabayaba

    Yabayabayaba L5: Dapper Member

    Messages:
    237
    Positive Ratings:
    66
    that is the cordon bounds, currently set to a really small area, use the:cordonedit: tool to edit the bounds of the cordon like you would a normal brush. if you have:cordonenable: selected only the things within the bounds will show in hammer, or be compiled.