Prop lighting texture issue

Discussion in 'Mapping Questions & Discussion' started by beefwellington, Mar 5, 2008.

  1. beefwellington

    beefwellington L1: Registered

    Messages:
    28
    Positive Ratings:
    0
    Before I go on, I already searched and did not find a thread about this.


    So whenever I place a prop_dynamic (like a capture point base or chalkboard) it has that pink and black checkered texture on the model when I load up my map in TF2. The writing on the chalkboard and green background to it show up find but its like the reflection of the model has that checkered texture. What am I doing wrong?
     
  2. dirtyminuth

    dirtyminuth L5: Dapper Member

    Messages:
    221
    Positive Ratings:
    14
    Quick answer: You need to build cubemaps. To do this, place an env_cubemap(point entity) in your map in Hammer, compile, and load your map in TF2. Once in the map, type "buildcubemaps" in the console. You many have to reload your map or restart TF2 to see the changes.

    There is a more formal process floating around somewhere. Paging cubemaps expert to beefwellington's thread, cubemap expert to beefweelington's thread...
     
  3. shpladoink

    shpladoink L3: Member

    Messages:
    108
    Positive Ratings:
    6
    Yeah, sounds like cubemaps. Most of the info you'll need on that is here.
     
  4. beefwellington

    beefwellington L1: Registered

    Messages:
    28
    Positive Ratings:
    0
    Yeah I JUST remembered env_cubemap after i posted this. Couldn't think of it's name but I got it working thanks.