Problems with the SDK and Hammer.

Discussion in 'Mapping Questions & Discussion' started by Beacon, Sep 7, 2009.

  1. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Good day all! I hope to become a contributing member here, as your forums seem to be a really great place.

    However first, I'm having some problems with the Source SDK and Hammer I hope you can help me out with.

    Firstly, I'm running Windows 7 RC, 64 bit, for reference.

    So basically, the problem is firstly, that the Source SDK is not working.
    I try to launch it through Steam, and the program appears to start, appearing in the Superbar, however nothing ever appears on screen (I left it going all day).

    However, this is not a huge deal as I can get around this by manually launching Hammer from its executable in the orangebox folder.

    Again, however, upon launching and choosing the TF2 launch option and trying to load my map, I get the message "Failed to load the default scheme file. The map views may be missing some visual elements." This is true, as I cannot see any measurements for my brushes - e.g. how high, wide, long something is. It's simply not there.

    Then, the second problem is that the editor will crash as soon as I attempt to browse for models. I create a prop entity and try to choose a world model, however a few seconds after clicking 'browse', the editor will close completely with no error message.

    I'm really stuck here, as this makes it really tricky to do anything but copy/paste existing brushes and fit them to already existing areas in my level.

    If anyone could help, I'd greatly appreciate it!

    Thanks,

    - Beacon
     
  2. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    If TF2 fully installed/up to date
    Same with SDK.
    Try validate the integrity of both caches.
    (I'm running W7 32bit (Still beta) and haven't seen anything like this)
     
  3. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Yes, both are fully updated and validated. I have also completely reinstalled the SDK to no avail.
     
  4. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Bump - I can't think of how to fix this, I really need some help.
     
  5. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    Already thought of reinstalling Source SDK/TF2/Steam/Windows?
     
  6. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Reinstalled Source SDK three times (properly). I suppose I could reinstall TF2 as well, but I don't know if I can downgrade from Windows 7 to Vista or not.

    And surely, others would be complaining if W7 was the problem.
     
  7. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Did you do "Refresh SDK Content" in the SDK launcher?

    I've gotten the "No Scheme" thing, but generally only when I was launching hammer directly with the SDK launcher not running.
     
  8. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    I don't get an SDK launcher window, that's the whole problem.
     
  9. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    D'oh!

    Erm, I mean--I see....

    Is there anything in the Windows event-log?
    If you run SDKLauncher.exe from a command-prompt, does it spit anything out as it dies?
     
  10. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    How do I launch it as you describe?
     
  11. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Code:
    c:\Program Files\Steam\steamapps\SteamUserName\sourcesdk\bin\SDKLauncher.exe
    I wouldn't expect it to start up properly without Steam running at the same time, of course.
     
  12. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    "SDKLauncher requires -game on the command line".
     
  13. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    OK, did a bit more sleuthing on my copy here.

    Try this:
    Code:
    cd "c:\Program Files\Steam\steamapps\SteamUserName\sourcesdk"
    bin\SDKLauncher.exe -game launcher
    
    That's how the main Steam app ought to be running it for you. (Which may or may not shed any light on the problem.)
     
    Last edited: Sep 8, 2009
  14. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Alright, I put -game <path to TF2 gameinfo file> and basically it just launched as usual. (E.g, it didn't launch.)

    So much for that :(
     
  15. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Also, using that quote (fixed up, was a little broken) I get the message that it can't find gameinfo.txt.
     
  16. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Bumping.
     
  17. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Are there any .mdmp files anywhere that magically multiply each time you try to run it?
     
  18. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    Well there are .mdmp files in almost all of the Steamapps game folders, including Source SDK - but there aren't a lot of them.
     
    Last edited: Sep 9, 2009
  19. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    If you try running the SDK and an mdmp file is created when it crashes/exits, you'll want to send that file to Valve and complain their SDK is crashing on you.
     
  20. Beacon

    Beacon L1: Registered

    Messages:
    24
    Positive Ratings:
    0
    The thing is it doesn't actually crash, it just never loads.

    Plus anyway, Valve apparently don't even support the SDK.