Problems with running a custom map on my server

Discussion in 'Mapping Questions & Discussion' started by Gignur, Oct 7, 2013.

  1. Gignur

    Gignur L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Hey all, hopefully this is the right place to ask this. I recently took the time to set up a dedicated Linux server (Ubuntu Server 11.04) to host a custom map I've been working on so my friends and I can play on it. I put a version of it on the server and we played on it, but there were some issues with it (on the mapping side, not the server).

    Well, I fixed the issues and now I want to put the new version up on the server so we can try it out again. I made sure to use hammer to save it as a new name to avoid version mismatches, compiled it, put the BSP where it should go, and updated the server's config files to start that map and only run that specific one.

    The problem is that now when I start the server it appears as offline. I don't really know what the problem is because when I change the config files back to the older version of the map the server appears back in the browser and people can play on it.

    Help is greatly appreciated, and if you need any info from me let me know.


    Almost forgot: The server is using Daniel Gibbs' TF2 server script, if that helps at all
     
    Last edited: Oct 7, 2013
  2. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,527
    I believe in the past having uppercase letters in the map name would cause issues with Linux servers, if that happens to apply to your map. I'm not familiar with them beyond that, though.
     
  3. Ice Crystal

    Ice Crystal L2: Junior Member

    Messages:
    79
    Positive Ratings:
    76
    If you havent already, try launching the server with the config you know works, joining it, then changing the map to the one you want. That way you can tell between a map issue or a config issue.

    Also, have you tried running it without Daniel Gibbs' tf2 server script? I dont know anything about it and don't know if that would have any effect.
     
  4. Gignur

    Gignur L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    I'm not really sure what the problem was, but it is all working now. According to the server browser the server was not responding/online but I went ahead and clicked join anyways and it connected just fine and now displays properly in the server browser. Weird, but at least it is working now.