Problem with Trigger entities

Discussion in 'Mapping Questions & Discussion' started by Aaron, Jul 3, 2011.

  1. Aaron

    Aaron L1: Registered

    Messages:
    3
    Positive Ratings:
    1
    I'm probably being an idiot and missing something, but when I go to edit a trigger after it's been put in the map, double clicking brings up the VisGroup dialog and editing using the keyboard shortcut removes all of the properties to do with the trigger and I have to start again. What am I doing wrong, or if it's a problem with Hammer, how do I fix it?

    Thanks. It's been bugging me for a while now and means map making for me is simply impossible to do.
     
  2. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    1) did you hit crtl+t to make it an entity int he first place
    2) do you have "solids" group select on? It in on the right side of hammer if you haven't touched that. It can also be added by going to tools or view and then screen elements. If you have solids selected, it won't show up as an entity, you need to switch to group or object.
     
  3. Aaron

    Aaron L1: Registered

    Messages:
    3
    Positive Ratings:
    1
    1. I have the problem with ones I put in and from prefabs. Sometimes it may be my fault (yes, Ctrl+T. D'oh for me) but ones from prefabs still have that same problem.
    2. I do indeed have that on.

    Ah. Got it. Select Groups instead. Thanks. :D
     
  4. TonyFox

    TonyFox L1: Registered

    Messages:
    6
    Positive Ratings:
    0
    Objects works just as well. Just as long as you're not in Solids mode. Related: Make sure you're in Objects/Groups mode when you copy/paste a brush entity as well, otherwise you'll just end up pasting the brush as a world brush, not an entity.
     
  5. Micnax

    aa Micnax I maek map

    Messages:
    2,057
    Positive Ratings:
    1,387
    Another problem that causes this is having the Ignore Group button enabled while trying to select an entity, just disable it and it'll work again.
     
  6. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    That's the same thing, actually. Ignore groups existed first, and then they expanded the options to differentiate between objects and groups and added the new buttons. However they still toggle the same thing (clicking one button clicks the other).