Problem with spawn rooms.

Discussion in 'Mapping Questions & Discussion' started by Midel, Dec 18, 2008.

  1. Midel

    Midel L1: Registered

    Messages:
    45
    Positive Ratings:
    14
    I'm working on a payload map with mort and at the moment having only one issue that prevents me from uploading the map for testing. The problem is getting players to spawn not only in the correct spawn room, but also in the correct order.

    There are two capture points before the end of the map. Each team gets has a new spawn as the map progresses. In all, there are 6 spawns, 3 for each team. Unfortunately, after tweaking and setting the rooms right, the players start in their respective rooms, but after the first point is captured, they wind up in the wrong rooms.

    I've used a team_control_point_round and assigned the spawns for the right team.

    How do set up the other spawns to work accordingly?
     
  2. Earl

    Earl L6: Sharp Member

    Messages:
    284
    Positive Ratings:
    37
    Make sure the first spawn room for each team is associated with a capture point. Else things get wonky.
     
  3. Midel

    Midel L1: Registered

    Messages:
    45
    Positive Ratings:
    14
    It did not work. Red players are still spawning in Blu rooms, despite filters and making sure each team spawn entity was associated with the correct room.

    Its now a 15 days left before the deadline and I'm sure someone with more coding experience would know how to fix it if they could see it.

    http://uploading.com/files/DV324MP7/pl_boondoggle_a01.vmf.html





    Any crit about anything else, I ask that you direct it to the correct thread:

    http://forums.tf2maps.net/showthread.php?t=4486&highlight=boondoggle
     
    • Thanks Thanks x 1
  4. bomc

    bomc L2: Junior Member

    Messages:
    83
    Positive Ratings:
    18
    You could look in the cp_game_enities and see what you have done wrong
     
  5. eerieone

    aa eerieone

    Messages:
    1,009
    Positive Ratings:
    569
    the first spawnrooms need to be associatat to a round, like "round a" or sth like that
    look at decompiled badwater and check info_player entities proporties with yours in the first respawn-rooms

    for the forward spawns to work correctly, you have to disable the spawns you don´t want to be active anymore, make sure for every state of the map there is only the group of info_playerspawn active that you want, the rest has to be disabled

    sry for the late answer, it´s not that nobody wants to help, but sometimes you miss a topic
    all you can do if no one answers is use the search function or compare with valve maps
    i had the same problem and solved it by doing so
     
    Last edited: Jan 17, 2009