Problem with menu photo

Discussion in 'Mapping Questions & Discussion' started by Pianodan, Jun 19, 2009.

  1. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I'm trying to add a photo to my opening chalkboard. I've created a transparent, 32-bit, uncompressed .tga, and converted to to .vtf using VTFedit, also creating a .vmt file. The problem is, when I actually load the game the picture appears, but flickering black over the opaque parts of the image. (The transparent parts are properly transparent). It looks as though I've got a black picture z-fighting with the one I actually want.

    What have I screwed up?
     
  2. TracerDX

    TracerDX L3: Member

    Messages:
    127
    Positive Ratings:
    25
    VTF flags and VMF? All I can guess is you didn't specify "$ignorez" 1.
     
  3. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I'm not sure what that means. Is that an option in VTFedit?
     
  4. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
  5. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    86
    Make sure your vmt is like this:

    "UnlitGeneric"
    {
    "$basetexture" "vgui\maps\your_vtf"
    "$translucent" 1
    "$ignorez" 1
    "$vertexcolor" 1
    }
     
  6. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    Unfortunately, no. I edited my .vmt file to match the one in the tutorial, but I'm still getting the black vs. picture z-fighting look. The .vmt originally said "LightmappedGeneric" rather than "UnlitGeneric" in the tutorial... am I doing something wrong with VTFEdit?

    It would be nice if there were a tutorial on how to do this with VTFEdit, and not from the command line using vtex. If I ever figure out how to do it, maybe I'll write one.

    Oh, and the line should be
    "$basetexture" "vgui\maps\menu_photos_ctf_Shooting_Gallery_a6"
    not
    "$basetexture" "vgui\maps\menu_photos_ctf_Shooting_Gallery_a6.vtf", right?
     
    Last edited: Jun 20, 2009
  7. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    Mine .vmt is exactly like l3eeron said and it works fine.

    You don't need vtf at the end.


    My guess is it's not your vmt but in how you saved the vtf. I use the photoshop plugin so I'm not familiar with vtf edit.
     
  8. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I'm sure that's possible, even likely. It may even be the original .tga has an issue. The problem is that I don't have photoshop, and I have a severe allergy to pirating software. I use either the Gimp or paint.net for my picture editing needs.
     
  9. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    Well, I didn't say pirate it. And nobody that OWNS photoshop pirated it.

    I just meant I din't know what settings you need to use. I suppose they are similar.

    Make sure you have dds5 checked. Without that I was unable to get transparency on sprays. And 8 bit alpha.
     
  10. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    Sorry, I didn't mean to imply anything. Just a knee-jerk reaction on these here interwebs.

    I do have both of those settings. As it turns out, there's a .vtf plugin for Paint.net, so I'll try that.
     
  11. Smashman

    Smashman L3: Member

    Messages:
    118
    Positive Ratings:
    37
    Perhaps a Screenshot would help?
     
  12. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I'm not sure it would, actually, as the effect isn't staic. Imagine what it looks like when you have two brushes overlapping, and the textures are flickering back and forth. (z-fighting) Now imagine a picture doing that with a black square the same size. That's pretty much it.