1. Hey there Guest,

    The game servers have moved to semi-dedicated hardware and IPs have changed. Please see front page server widget for up-to-date game server information.

Problem when compiling

Discussion in 'Mapping Questions & Discussion' started by mazata, Feb 22, 2018.

  1. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
    So what happend was that when I compile my map, a window pops up that says that windows cant find the file.

    Anny ideas on how to fix this??
     
  2. obodobear

    obodobear L4: Comfortable Member

    Messages:
    165
    Positive Ratings:
    30
    Maybe try saving the .vmf under a different filename, or check the file name or directory. Also are you using Compile Pal, or the compiler in hammer?
     
  3. A Piece of Shit.

    A Piece of Shit. L1: Registered

    Messages:
    15
    Positive Ratings:
    3
    Also try to find an error in the compile process. Then you'll find the answer probably.
     
  4. Vel0city

    aa Vel0city func_fish

    Messages:
    1,938
    Positive Ratings:
    1,542
    That error happens because the first stage of the compile process, VBSP, didn't finish its job because of an error resulting in a failed compile. This can be caused by leaks, invalid brushes, too complex of a geometry for VBSP to figure out, etc. Post your compile log here: http://www.interlopers.net/errors/?page=errors&params= and see what it says.
     
    • Agree Agree x 1
  5. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
    I fixed 1 error but it still pops up and thw website doesnt tell me annything
     
  6. A Piece of Shit.

    A Piece of Shit. L1: Registered

    Messages:
    15
    Positive Ratings:
    3
    If all hope is lost just google it, you can ofc post it here but the change that the answer is out there is huge.
     
  7. Vel0city

    aa Vel0city func_fish

    Messages:
    1,938
    Positive Ratings:
    1,542
    Then post your compile log here.
     
  8. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.vmf"

    Valve Software - vbsp.exe (Oct 14 2017)
    2 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Error: displacement found on a(n) func_detail entity - not supported (entity 585, brush 0)


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta"

    Valve Software - vvis.exe (Oct 14 2017)
    2 threads
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta"

    Valve Software - vrad.exe SSE (Oct 14 2017)

    Valve Radiosity Simulator
    2 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\ctf_farmfall_beta.bsp"

    The command failed. Windows reported the error:
    "Det går inte att hitta filen"
    Det går inte att hitta filen = not able to find the file
     
  9. Vel0city

    aa Vel0city func_fish

    Messages:
    1,938
    Positive Ratings:
    1,542
    "Error: displacement found on a(n) func_detail entity - not supported (entity 585, brush 0)"

    I don't know how you missed this error in the Interlopers error checker because it definitely should've told you. But yeah, fix this, compile again.
     
  10. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
    I dont know what to fix, I've turned all my displacements into non-func_detail
     
  11. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    873
    Positive Ratings:
    592
    Just to be sure you got every displacement, disable everything in your visgroups, enable displacements and only displacements, then select everything and hit "To World". Then enable everything and compile again.
     
  12. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
    Still doesnt work
     
  13. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    873
    Positive Ratings:
    592
    Are you giving us the most recent version of your compile log?
     
  14. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
    The only thing that I did was to do what you said but here it is again:

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.vmf"

    Valve Software - vbsp.exe (Oct 14 2017)
    2 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Error: displacement found on a(n) func_detail entity - not supported (entity 585, brush 0)


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta"

    Valve Software - vvis.exe (Oct 14 2017)
    2 threads
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta"

    Valve Software - vrad.exe SSE (Oct 14 2017)

    Valve Radiosity Simulator
    2 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\ctf_farmfall_beta.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\ctf_farmfall_beta.bsp"

    The command failed. Windows reported the error:
    "Det går inte att hitta filen."
     
  15. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
     
  16. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,377
    Boom. You tried converting a displacement (or several) into a func_detail and the whole process is aborting when it finds it. Displacements are already detail geometry. Find it, or them, and hit Tools > Move to World.
     
  17. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    873
    Positive Ratings:
    592
    We already figured that out, thank you.
     
  18. Crash

    aa Crash func_nerd

    Messages:
    3,191
    Positive Ratings:
    5,018
    Actually, I believe if you turn on displacements only it wont show up because it's considering it as a func_detail over a displacement. Turn on only func_details and look for a displacement surface. If you absolutely still can't find it, you can cut the map into sections with the cordon tool and compile smaller and smaller parts of the map, looking for the error in the log each time.
     
  19. henke37

    aa henke37

    Messages:
    1,954
    Positive Ratings:
    465
    The keys here are those id numbers. The brush number is bugged out (not your fault, I replicated the issue with a trivial test file), so, that's useless. The entity number is also bugged out. Instead of being the entity id (a stable number explicitly given to each entity), it's the index. So open up the vmf and find the 585th entity block from the beginning of the file.
     
  20. mazata

    mazata L2: Junior Member

    Messages:
    89
    Positive Ratings:
    29
    Thanks all for the help!!! It works now!