poster overlay bug

Discussion in 'Mapping Questions & Discussion' started by DataTraveler, Mar 12, 2010.

  1. DataTraveler

    DataTraveler L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    Hello,
    I was trying to make a poster overlay with this tutorial . I did everything correct, but at the end I get white color surrounding my poster. How to remove it?

    [​IMG]
     
  2. FissionMetroid101

    FissionMetroid101 L2: Junior Member

    Messages:
    65
    Positive Ratings:
    108
    Hmm, have you tried the level ingame to see if that problem's still there? Because I've had a similar error with sprites, but they fixed themselves when I compiled the map.
     
    • Thanks Thanks x 1
  3. DataTraveler

    DataTraveler L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    I have another question. Why on my textures are red (!) ?

    Here's a pic of that:
    [​IMG]



    And I tryed as you said but still same
    Here:
    [​IMG]
     
  4. Tapp

    Tapp L10: Glamorous Member

    Messages:
    776
    Positive Ratings:
    211
    when converting the poster to a vtf file, was it a png file? Because vtf only recognises the transparency in png files. Also, make sure that the vmt has translucency in it.
     
    • Thanks Thanks x 1
  5. Mick-a-nator

    aa Mick-a-nator

    Messages:
    640
    Positive Ratings:
    314
    isn't .tga the transparent format of choice for vtf, nay the only format of choice for vtf?

    anyway, try checking the alpha channel and transparency in your original file.
     
    • Thanks Thanks x 1
  6. Cynick

    Cynick L4: Comfortable Member

    Messages:
    153
    Positive Ratings:
    143
    Make sure you save as a 32 bit TGA or a 32 Bit PNG before converting. 24 Bit will not include the alpha (transparency) channel in your image, giving your image a white border. Also, make sure you are actually making the edges transparent in whatever image editor you use.
     
    • Thanks Thanks x 1
  7. Exist

    Exist L6: Sharp Member

    Messages:
    306
    Positive Ratings:
    112
    In the VMT file for the overlay, add this

    $translucent 1

    If you didn't remove the white outline in Photoshop or The Gimp, Google how to do so.
     
    • Thanks Thanks x 1
  8. DataTraveler

    DataTraveler L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    This is how my vmt looks like
    Code:
    "LightmappedGeneric"
    {
    "$basetexture" "signs/atsargiai_kont"
    "$decal" 1
    "$decalscale" 0.25
    "$translucent" 1
    "%keywords" "tf"
    }
    
    And I did every thing like you said saved as .tga 32bit but still the same.
    BTW I use PhotoShop CS3.
    Any more ideas how to solve that?
     
  9. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,570
    I'm pretty sure there's a PS plugin that allows you to save directly to .VMT format.

    It sounds like you havn't set up the transparency in the image properly.
     
    • Thanks Thanks x 1
  10. DataTraveler

    DataTraveler L1: Registered

    Messages:
    29
    Positive Ratings:
    1
  11. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,570
    When i first had trouble setting up my transparency in a .vmt i simply took an existing .vmt (extracted from the TF2 .gcf), deleted the existing layer and replaced it with my own. That worked (it was for a spray, so i didn't really need to edit the .vtf). I then figured out configuring an alpha channel after, when i understood more about PS channels.

    edit: http://nemesis.thewavelength.net/index.php?c=154&o=30

    photoshop .vmt plugin.
     
    • Thanks Thanks x 1
    Last edited: Mar 13, 2010
  12. DataTraveler

    DataTraveler L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    Thanks it helped me. But still not perfect.
    [​IMG]

    Any new ideas how to fix that?