Portal 2 FPS config

Discussion in 'Off Topic' started by Zhan, Apr 19, 2011.

  1. Zhan

    Zhan L5: Dapper Member

    Messages:
    208
    Positive Ratings:
    114
    Thought this might be useful to the few of you out there playing Portal 2 on suboptimal computers! Just copy the block of code and put it in a file called autoexec.cfg in the directory Steam/steamapps/common/portal 2/portal2/cfg/.

    It occasionally and unpredictably crashes when turrets are firing, so suggestions on how to fix that are appreciated.

    Code:
    // Zhan's modifications of Chris' TF2 FPS config, to work for Portal 2.
    // Chris suggests command line options like "-dxlevel 81 -sw -w YOURWIDTH -h YOURHEIGHT -console -noborder -nojoy -noipx -novid -useforcedmparms -noforcemaccel -noforcemspd"
    
    sv_cheats "1"
    
    cl_cmdrate "40"
    cl_interp "0.025" // Change to 0.0375 for hitscan
    cl_interp_ratio "1"
    cl_lagcompensation "1"
    cl_pred_optimize "2"
    cl_smooth "0"
    cl_smoothtime "0.01"
    cl_updaterate "40"
    rate "35000"
    
    cl_playerspraydisable "1"
    r_decals "9" // Enough to show scatter pellets without decreasing performance
    r_spray_lifetime "0"
    
    blink_duration "0"
    r_eyes "0"
    r_flex "0"
    r_lod "2"
    r_rootlod "2"
    r_teeth "0"
    flex_rules "0"
    flex_smooth "0"
    
    g_ragdoll_fadespeed "0"
    g_ragdoll_lvfadespeed "0"
    ragdoll_sleepaftertime "0"
    
    props_break_max_pieces "0"
    r_propsmaxdist "1"
    violence_ablood "0"
    violence_agibs "0"
    violence_hblood "0"
    violence_hgibs "0"
    
    adsp_debug "0"
    cl_clearhinthistory "1"
    cl_debugrumble "0"
    cl_rumblescale "0"
    mat_debugdepthval "0"
    mat_debugdepthvalmax "0"
    mat_debug_postprocessing_effects "0"
    
    cl_burninggibs "0"
    cl_detaildist "0"
    cl_detailfade "0"
    cl_drawmonitors "0"
    cl_ejectbrass "0"
    cl_ragdoll_collide "0"
    cl_show_splashes "0"
    func_break_max_pieces "1"
    glow_outline_effect_enable "0"
    mat_aaquality "0"
    mat_antialias "0"
    mat_autoexposure_max "0"
    mat_autoexposure_min "0"
    mat_bloomscale "0"
    mat_bloom_scalefactor_scalar "0"
    mat_bumpmap "0"
    mat_colcorrection_disableentities "1"
    mat_compressedtextures "1"
    mat_disable_bloom "1"
    mat_disable_fancy_blending "1"
    mat_envmapsize "0"
    mat_envmaptgasize "0"
    mat_excludetextures "1"
    mat_fastnobump "0"
    mat_fastspecular "0"
    mat_filterlightmaps "0"
    mat_filtertextures "0"
    mat_forceaniso "0"
    mat_forcehardwaresync "0"
    // mat_hdr_level "0" // this was in Chris' config but it appears to break the lighting in Portal 2
    mat_max_worldmesh_vertices "0"
    mat_mipmaptextures "1"
    mat_monitorgamma "1.8" // Controls brightness, try 1.8 to get it brighter or 2.2 to get it darker. Only works in fullscreen.
    mat_motion_blur_enabled "0"
    mat_non_hdr_bloom_scalefactor "0"
    mat_parallaxmap "0"
    mat_picmip "1"
    mat_postprocess_x "0"
    mat_postprocess_y "0"
    mat_reducefillrate "1"
    mat_reduceparticles "1"
    mat_softwarelighting "0"
    mat_software_aa_blur_one_pixel_lines "0"
    mat_software_aa_blur_one_pixel_lines "0"
    mat_software_aa_strength "0"
    mat_software_aa_strength "0"
    mat_software_aa_strength_vgui "0"
    mat_software_aa_strength_vgui "0"
    mat_software_aa_tap_offset "0"
    mat_software_aa_tap_offset "0"
    mat_specular "0"
    mat_wateroverlaysize "2"
    mp_usehwmmodels "0"
    mp_usehwmvcds "0"
    rope_averagelight "0"
    rope_collide "0"
    rope_rendersolid "0"
    rope_shake "0"
    rope_smooth "0"
    rope_smooth_enlarge "0"
    rope_smooth_maxalpha "0"
    rope_smooth_maxalphawidth "0"
    rope_smooth_minalpha "0"
    rope_smooth_minwidth "0"
    rope_solid_maxalpha "0"
    rope_solid_maxwidth "0"
    rope_solid_minalpha "0"
    rope_solid_minwidth "0"
    rope_subdiv "0"
    rope_wind_dist "0"
    r_3dsky "0"
    r_ambientboost "0"
    r_ambientfactor "0"
    r_ambientmin "0"
    r_avglight "0"
    r_bloomtintb "0"
    r_bloomtintexponent "0"
    r_bloomtintg "0"
    r_bloomtintr "0"
    r_cheapwaterend "1"
    r_cheapwaterstart "1"
    r_decalstaticprops "0"
    r_dopixelvisibility "0"
    r_drawbatchdecals "0"
    r_drawdetailprops "0"
    r_drawflecks "0"
    r_drawmodeldecals "0"
    r_drawspecificstaticprop "0"
    // r_dynamic "0" // commented this out to try and stop Portal 2 crashing when turrets are firing but not sure if it helps, might get better performance with it set to 0
    r_eyemove "0"
    
    cl_predict "1"
    cl_predictweapons "1"
    cl_showpluginmessages "0"
    
    cl_forcepreload "1" // Preloads maps, may cause a few seconds more loading the map at the benefit of a more consistent FPS (because the whole map is preloaded)
    //m_rawinput "1" // Uncomment to enable raw mouse input -- DO NOT ENABLE IF YOU ARE USING XFIRE OVERLAY
    mat_bufferprimitives "1"
    mat_clipz "1" // FX owners should set this to 0
    mat_forcehardwaresync "0"
    mat_framebuffercopyoverlaysize "0"
    mat_levelflush "0"
    mat_maxframelatency "0"
    mat_vsync "0"
    r_fastzreject "-1" // Some ATI cards aren't autodetected, if you know that your card supports it, try setting it to 1.
    r_hunkalloclightmaps "0"
    r_lightcache_zbuffercache "0"
    r_occlusion "1"
    r_unloadlightmaps "0"
    
    cl_threaded_bone_setup "0"
    mat_queue_mode "-1"
    r_threaded_particles "1"
    r_queued_decals "0"
    r_queued_post_processing "0"
    r_queued_ropes "1"
    
    sv_cheats "0"
     
    • Thanks Thanks x 3
  2. Mr. Wimples

    Mr. Wimples L6: Sharp Member

    Messages:
    276
    Positive Ratings:
    202
    Forgot to mention it ups the game difficulty:
    TURRETS SHOOT GAME-CRASHING BULLETS

    Also, my crappy laptop for away-from-home is happy.