Please Explain Trigger_Push To Me

Discussion in 'Mapping Questions & Discussion' started by Stormcaller3801, Dec 16, 2009.

  1. Stormcaller3801

    Stormcaller3801 L5: Dapper Member

    Messages:
    249
    Positive Ratings:
    28
    I'm working on a map, and one of the key features is a series of ramps you can run up and then be launched from, with the goal of landing on (or in) a given target.

    When I set the push speed to 40000 inches/second, it reset it to 40. Which, as one might expect, just sort of nudge the player a bit. When I set it to 40 and the alternate tick to 1000, I found myself on the other side of the map. When I set it to 4 and 1000, I was getting nudges again. Finally, I set it to 4000 and 1, and that seemed to work. Sort of.

    Then I played with the angle. I tried using the 'point at' tool. I pointed it at a prop beyond my target. That launched me straight forward into a wall. I tried altering the angle. Still hit the wall. I set the angle to 60 0 0, and hit the wall. I set the angle to -60 0 0, and still hit the wall.

    Then I deleted the trigger, rebuilt it without ever pointing at anything, set the angle to -60 0 0, and was launched sideways into a different wall.

    After much experimentation, -90 90 0 appears to achieve an angle that works. But, it doesn't always push you. If you walk up the ramp, you get where you're going. If you walk up and jump, you fall short.

    I extended the ramp to ensure nobody could just walk under the trigger and get launched in the air by their head being inside it. Then walking up the ramp did little or nothing, and jumping from the ramp could land you on the target. Or drop you short. The end result appears random.

    Furthermore, I cloned the whole thing and set up a second one. They're aligned to the grid, and there's an identical target an identical distance at an identical angle. This one, you miss the target regularly.

    So I'm more or less stumped here. Someone please explain how exactly this all works, because it doesn't appear to follow any sort of logical pattern that I can discern.
     
  2. Daedryon

    Daedryon L3: Member

    Messages:
    134
    Positive Ratings:
    3
    Mhm, I gave up on trigger push while making a pool with a diving board.

    It's hard to explain.

    It's best to just say trigger push is fucked in the head.

    That sums it all up.
     
  3. wiseguy149

    wiseguy149 Emperor of Entities and Amateur of Aesthetics

    Messages:
    103
    Positive Ratings:
    160
    If you want to launch somone and it's at about a 50 degree angle or less, the best way to do it (from my experience with the launchpad in walkway) is to make a short ramp with a func_conveyor that has a very high speed.


    trigger_push is really tricky when trying to push people upwards.
     
  4. Nutomic

    Nutomic L11: Posh Member

    Messages:
    888
    Positive Ratings:
    177
    @Daedryon: Trigger_push pushes things into the set direction, with the set strength. Not difficult at all.
     
  5. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    trigger_push can't pick someone up off the ground for some reason, they have to jump first. This might be the reason for strange occurrences. However I would suggest trying what wiseguy said, a conveyor is much more appropriate for this situation.
     
    • Thanks Thanks x 1
  6. Pseudo

    Pseudo L6: Sharp Member

    Messages:
    319
    Positive Ratings:
    149
    The "point at" tool is slightly bugged in Hammer. It will always change the "angles" keyvalue but trigger_push doesn't use "angles", it uses "pushdir". You could turn off Smart Edit and copy the numbers from angles to pushdir (or movedir for func_conveyor).