Payload HUD only works for team RED

Discussion in 'Mapping Questions & Discussion' started by moustetail, Mar 20, 2017.

  1. moustetail

    moustetail L1: Registered

    Messages:
    8
    Positive Ratings:
    4
    Hey! I am in the process of writing a python script that can automatically mirror or rotate your maps. It can already fix names, triggers, team numbers, displacements, models, textures, ignore objects on the noCopy layer , and will also build your map with VBSP, VVIS and VRAD if desired.

    I tested it with several KOTH maps, and it worked fine. However, I get strange results for payload maps. I copied the payload template from the gametype library, deleted half of it, centered it, and marked objects that should not be copied. Both teams can push the cart. However, only the RED cart shows up on the HUD. BLU can cap the final point, but will not win. RED can win like normal. I have spent several hours trying to find the mistake, fixed many minor mistakes, searched the internet for any tutorials on payload race, (They don't seem to exist) but those two major issues remain.

    The map file is attached below. (You can open and edit it in hammer, it's indistinguishable from a hammer-generated VMF) I expect there to be a simple mistake, like a trigger misconfigured or a a variable having the wrong formatting.
    pl_deep_mine0001.png
    (here I just capped the point but did not win)
     

    Attached Files:

  2. Xi.Cynx

    aa Xi.Cynx Former Alias: †Blade†

    Messages:
    772
    Positive Ratings:
    734
    Just out of curiosity, have to tried comparing the logics and entities with what you have to an actual PLR map like pipeline? I think that would be your best bet in figuring this one out. You can head over to the thread in my signature if you want to download the decompiled version of it quickly.
     
  3. moustetail

    moustetail L1: Registered

    Messages:
    8
    Positive Ratings:
    4
    I compared the logic with the map template. The downloads for the your official map source seems to still be broken, even after you attempted to fix them this morning. (401 permision denied) I assume there is some simple variable name that needs to change.