Parts of my map not updating {solved}

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

ComradeRoffel

L2: Junior Member
Apr 7, 2017
60
Compile log:

** Executing...
** Command: "D:\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
** Parameters: -game "D:\Steam\steamapps\common\Team Fortress 2\tf" "D:\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.vmf"

Valve Software - vbsp.exe (Mar 6 2018)
4 threads
materialPath: D:\Steam\steamapps\common\Team Fortress 2\tf\materials
Loading D:\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.vmf
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
Patching WVT material: maps/sd_gray_a1/dev/dev_blendmeasure2_wvt_patch
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...done (0)
Building Faces...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing D:\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.prt...Building visibility clusters...
done (0)
*** Error: Skybox vtf files for skybox/sky_coastal_01 weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/sky_coastal_01 to build the default cubemap!
*** Error: Skybox vtf files for skybox/sky_coastal_01 weren't compiled with the same size texture and/or same flags!
Can't load skybox file skybox/sky_coastal_01 to build the default cubemap!
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (97308 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 99 texinfos to 61
Reduced 19 texdatas to 18 (463 bytes to 441)
Writing D:\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.bsp
Wrote ZIP buffer, estimated size 467, actual size 387
0 seconds elapsed

** Executing...
** Command: "D:\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
** Parameters: -game "D:\Steam\steamapps\common\Team Fortress 2\tf" -fast "D:\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1"

Valve Software - vvis.exe (Mar 6 2018)
fastvis = true
4 threads
reading d:\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.bsp
reading d:\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.prt
137 portalclusters
274 numportals
BasePortalVis: 0...1...2...3...4...5...6...7...8...9...10 (0)
Optimized: 478 visible clusters (4.41%)
Total clusters visible: 10843
Average clusters visible: 79
Building PAS...
Average clusters audible: 104
visdatasize:5533 compressed from 6576
writing d:\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.bsp
0 seconds elapsed

** Executing...
** Command: "D:\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
** Parameters: -game "D:\Steam\steamapps\common\Team Fortress 2\tf" -noextra "D:\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1"

Valve Software - vrad.exe SSE (Mar 6 2018)

Valve Radiosity Simulator
4 threads
[Reading texlights from 'lights.rad']
unknown light specifier type - lights

[56 texlights parsed from 'lights.rad']

Loading d:\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.bsp
Setting up ray-trace acceleration structure... Done (0.06 seconds)
670 faces
146732 square feet [21129550.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
670 patches before subdivision
21820 patches after subdivision
sun extent from map=0.008727
49 direct lights
BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (0)
BuildVisLeafs: 0...1...2...3...4...5...6...7...8...9...10 (1)
transfers 2232295, max 326
transfer lists: 17.0 megs
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #1 added RGB(100007, 71500, 76316)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #2 added RGB(16783, 7968, 9345)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #3 added RGB(3284, 925, 1237)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #4 added RGB(771, 110, 171)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #5 added RGB(232, 13, 24)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #6 added RGB(91, 2, 4)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #7 added RGB(44, 0, 1)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #8 added RGB(24, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #9 added RGB(14, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #10 added RGB(8, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #11 added RGB(5, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #12 added RGB(3, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #13 added RGB(2, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #14 added RGB(1, 0, 0)
GatherLight: 0...1...2...3...4...5...6...7...8...9...10 (0)
Bounce #15 added RGB(1, 0, 0)
Build Patch/Sample Hash Table(s).....Done<0.0058 sec>
FinalLightFace: 0...1...2...3...4...5...6...7...8...9...10 (0)
FinalLightFace Done
0 of 0 (0% of) surface lights went in leaf ambient cubes.
ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (1)
Writing leaf ambient...done
Ready to Finish

Object names Objects/Maxobjs Memory / Maxmem Fullness
------------ --------------- --------------- --------
models 21/1024 1008/49152 ( 2.1%)
brushes 270/8192 3240/98304 ( 3.3%)
brushsides 1637/65536 13096/524288 ( 2.5%)
planes 490/65536 9800/1310720 ( 0.7%)
vertexes 1222/65536 14664/786432 ( 1.9%)
nodes 515/65536 16480/2097152 ( 0.8%)
texinfos 61/12288 4392/884736 ( 0.5%)
texdata 18/2048 576/65536 ( 0.9%)
dispinfos 0/0 0/0 ( 0.0%)
disp_verts 0/0 0/0 ( 0.0%)
disp_tris 0/0 0/0 ( 0.0%)
disp_lmsamples 0/0 0/0 ( 0.0%)
faces 670/65536 37520/3670016 ( 1.0%)
hdr faces 0/65536 0/3670016 ( 0.0%)
origfaces 434/65536 24304/3670016 ( 0.7%)
leaves 537/65536 17184/2097152 ( 0.8%)
leaffaces 748/65536 1496/131072 ( 1.1%)
leafbrushes 636/65536 1272/131072 ( 1.0%)
areas 4/256 32/2048 ( 1.6%)
surfedges 4742/512000 18968/2048000 ( 0.9%)
edges 2831/256000 11324/1024000 ( 1.1%)
LDR worldlights 49/8192 4312/720896 ( 0.6%)
HDR worldlights 0/8192 0/720896 ( 0.0%)
leafwaterdata 0/32768 0/393216 ( 0.0%)
waterstrips 40/32768 400/327680 ( 0.1%)
waterverts 0/65536 0/786432 ( 0.0%)
waterindices 588/65536 1176/131072 ( 0.9%)
cubemapsamples 0/1024 0/16384 ( 0.0%)
overlays 0/512 0/180224 ( 0.0%)
LDR lightdata [variable] 356604/0 ( 0.0%)
HDR lightdata [variable] 0/0 ( 0.0%)
visdata [variable] 5533/16777216 ( 0.0%)
entdata [variable] 37574/393216 ( 9.6%)
LDR ambient table 537/65536 2148/262144 ( 0.8%)
HDR ambient table 537/65536 2148/262144 ( 0.8%)
LDR leaf ambient 2214/65536 61992/1835008 ( 3.4%)
HDR leaf ambient 537/65536 15036/1835008 ( 0.8%)
occluders 0/0 0/0 ( 0.0%)
occluder polygons 0/0 0/0 ( 0.0%)
occluder vert ind 0/0 0/0 ( 0.0%)
detail props [variable] 1/12 ( 8.3%)
static props [variable] 1/12 ( 8.3%)
pakfile [variable] 387/0 ( 0.0%)
physics [variable] 97308/4194304 ( 2.3%)
physics terrain [variable] 2/1048576 ( 0.0%)

Level flags = 0

Total triangle count: 1678
Writing d:\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.bsp
3 seconds elapsed

** Executing...
** Command: Copy File
** Parameters: "D:\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\sd_gray_a1.bsp" "D:\Steam\steamapps\common\Team Fortress 2\tf\maps\sd_gray_a1.bsp"






I see no indication of a leak or I am just blind. also when I load up the map and noclip to the missing area, I am still able to walk on the ground, however my character renders poorly

View attachment 79902
 

ComradeRoffel

L2: Junior Member
Apr 7, 2017
60
hey first you can run it through this: http://www.interlopers.net/index.php?page=errors
the issue could lie in areaportals if you messed with them.
I removed the fog controller the color correction and the shadow controller, ran vvis in normal and turned on hdr and I changed the skybox to an hdr one. Nothing worked but when I turned all the brushes missing into a func_detail everything was working again:
sd_grey_a10000.jpg