Overlays are black

Discussion in 'Mapping Questions & Discussion' started by Gameslave, Mar 29, 2009.

  1. Gameslave

    Gameslave L1: Registered

    Messages:
    13
    Positive Ratings:
    0
    Exactly what the title says, when I make an overlay and run the map, it just ends up being a black square. I'm sure the reason is simple, but I haven't been able to find anything about it.....
     
  2. Ravidge

    aa Ravidge Grand Vizier

    Messages:
    1,544
    Positive Ratings:
    2,518
    Do you have any light entities in your map?
    fullbright mode can cause overlays to appear black.
     
  3. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    I had this same problem once ill see if i can remember what it was. Ok I couldnt find my post so im going to guess. I believe it was caused by a leak. if no leak look for your env entities.
     
    Last edited: Mar 30, 2009
  4. Smashman

    Smashman L3: Member

    Messages:
    118
    Positive Ratings:
    37
    I had this.
    Ya just whack some lights in.
    I know it seems like there is light on the map, but it's an automatic thing.
    Just add some light entites in, and voila, instant overlay!
     
  5. Gameslave

    Gameslave L1: Registered

    Messages:
    13
    Positive Ratings:
    0
    Thanks, but I'm not that new! :p

    I have lighting in the map, I tested different overlays in different lighted areas, none worked.

    My friend said something about he put a cubemap right in front of the overlay and it worked, but I'm too tired to check :sleep:
     
  6. fisheye

    fisheye L1: Registered

    Messages:
    7
    Positive Ratings:
    1
    I need to restart my maps twice after building cubemaps before my overlays will look right.