Oh No! a leek!

Discussion in 'Mapping Questions & Discussion' started by YOYOYO, Nov 2, 2017.

  1. YOYOYO

    YOYOYO L7: Fancy Member

    Messages:
    416
    Positive Ratings:
    230
    Oh no! its the infamous water leak. I'm making an underground room with sewer water, but it keeps looking like this:
    koth_dev_a10000.jpg
    Here's the compile thingy (I couldn't find a leak anywhere, and the point file wasn't working, so here yah go):


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_dev_a1.vmf"
    Valve Software - vbsp.exe (Oct 14 2017)
    4 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_dev_a1.vmf
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (-1527.9 255.8 -608.0)
    Leaf 0 contents: CONTENTS_WATER CONTENTS_TRANSLUCENT
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_WATER
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_WATER
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_WATER
    Candidate brush IDs: Brush 836:
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (-1527.9 255.8 -608.0)
    Leaf 0 contents: CONTENTS_WATER CONTENTS_TRANSLUCENT
    Leaf 1 contents:
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_WATER
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_WATER
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_WATER
    Candidate brush IDs: Brush 836:
    Processing areas...done (0)
    Building Faces...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (0)
    writing C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_dev_a1.prt...Building visibility clusters...
    done (0)
    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!
    *** Error: Skybox vtf files for skybox/sky_tf2_04 weren't compiled with the same size texture and/or same flags!
    Can't load skybox file skybox/sky_tf2_04 to build the default cubemap!
    Finding displacement neighbors...
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (0) (15980 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Water found with no water_lod_control entity, creating a default one.
    Compacting texture/material tables...
    Reduced 71 texinfos to 40
    Reduced 9 texdatas to 8 (242 bytes to 199)
    Writing C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_dev_a1.bsp
    Wrote ZIP buffer, estimated size 425, actual size 345
    0 seconds elapsed
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" -fast "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_dev_a1"
    vvis launcher error: can't load vvis_dll.dll
    The specified procedure could not be found.

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_dev_a1"
    vrad_launcher error: can't load vrad_dll.dll
    The specified procedure could not be found.

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\koth_dev_a1.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\koth_dev_a1.bsp"

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\hl2.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" +map "koth_dev_a1" -steam
     
  2. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    753
    Positive Ratings:
    512
    VVIS isn't running, it looks like you have an error with one of your files. Not a leak.
     
    • Thanks Thanks x 1
  3. YOYOYO

    YOYOYO L7: Fancy Member

    Messages:
    416
    Positive Ratings:
    230
    What's a VVIS?
     
  4. hutty

    aa hutty

    Messages:
    471
    Positive Ratings:
    373
    The thing that makes the leaks
    pro tip, kill it and never see leaks again /s


    VVIS is the bit that checks your map for holes and sets up the optimizations ( so your map doesn't have low fps). If it doesn't do its thing your map won't get lighting either.

    idk exactly whats going on with your map, did you compile on very low settings?

    there are some errors that may or may not be related, plop them in here http://www.interlopers.net/errors/ for more details
     
    • Thanks Thanks x 1
  5. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    753
    Positive Ratings:
    512
    Actually, VBSP checks for leaks. Everything else is accurate.
     
    • Thanks Thanks x 1
  6. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    VRAD can work perfectly fine even without VVIS.
     
    • Respectfully Disagree Respectfully Disagree x 6
  7. Da Spud Lord

    aa Da Spud Lord L0: Crappy Member

    Messages:
    753
    Positive Ratings:
    512
    VRAD only does direct lighting without VVIS- no light bouncing- so yes, you'll get lighting, but it will look weird and wonky- I'd hardly call that "perfectly fine".
     
  8. 200

    200 L2: Junior Member

    Messages:
    50
    Positive Ratings:
    70
    You probably have the same error me and a couple of other people are having after the latest TF2 updates. More info here. I managed to fix it by completely removing contents of my /bin folder and then verifying the game cache from the Steam Library. Also, you have a huge brush somewhere near (-1527.9 255.8 -608.0), just split it in half to get rid of this error.
     
  9. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    ah you're right, what I meant to say is that VVIS isn't required at all to use VRAD, since it does work and give a good impression on the final result without VVIS.

    Edit: How is this disagreeable? @henke37 Have you never tried to run VRAD without VVIS?
    Please explain why you voted this way, so I can learn from it. Otherwise the rating is pointless and unneeded
     
    • Respectfully Disagree Respectfully Disagree x 1
    Last edited: Nov 18, 2017
  10. YOYOYO

    YOYOYO L7: Fancy Member

    Messages:
    416
    Positive Ratings:
    230
    Already did that
     
  11. hutty

    aa hutty

    Messages:
    471
    Positive Ratings:
    373
    Do other maps compile fine?
     
  12. YOYOYO

    YOYOYO L7: Fancy Member

    Messages:
    416
    Positive Ratings:
    230
    just tested, that is a no
     
    Last edited: Nov 3, 2017
  13. hutty

    aa hutty

    Messages:
    471
    Positive Ratings:
    373
    Well, thats not good, sounds like you got a serious issue with your installation.
     
  14. YOYOYO

    YOYOYO L7: Fancy Member

    Messages:
    416
    Positive Ratings:
    230
    oh, damn. I'll try to fix it myself then
     
  15. YOYOYO

    YOYOYO L7: Fancy Member

    Messages:
    416
    Positive Ratings:
    230
    wait, by other maps, do you mean valve maps included? because valve maps work fine. Even custom maps. Just my maps are broken, no mater what water.
     
  16. hutty

    aa hutty

    Messages:
    471
    Positive Ratings:
    373
    I meant if you make a new map that is just a simple box with a spawn, will it still fail to compile. (or take a map that others can compile and seeing if it works on your machine)
     
  17. YOYOYO

    YOYOYO L7: Fancy Member

    Messages:
    416
    Positive Ratings:
    230
    btw, this helped me ALOT
     
  18. mat_phong 0

    mat_phong 0 L1: Registered

    Messages:
    24
    Positive Ratings:
    9
    Oh no! A leek!
    upload_2017-11-18_17-39-40.png
    Anyways, have you checked if the water is in any way outside of the skybox area?
     
    • Funny Funny x 2