Odd Issue: Spawnpoints

Discussion in 'Mapping Questions & Discussion' started by MissionBrief_, Jun 22, 2015.

  1. MissionBrief_

    MissionBrief_ L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    After a long lenthy attempt to fix the spawn points found on my map in the Steam Chat the result was: "Post it to the forums" and so here I present to you, the map with spawnpoints from hell.

    Issue: For an unknown reason Red Players spawn at a spawnpoint that is clearly 'Team: Blue' and nobody has a clue as to why, see http://gyazo.com/a65ff242f1827017d1cd6ad794432927

    Info: All of the spawn points are under the same entity name, Players cannot seem to spawn where Red is supposed to spawn, the cause is entirely unknown. There is an input entity in the Blue Spawn entities to disable after the first capture point has been capped.

    Red Spawn: http://gyazo.com/e0d60b18a88aed8b9c3a738006bc936a, note: the player spawn is 16 Hammer unit blocks above the ground.

    VMF: https://onedrive.live.com/redir?resid=1DD360DE6F0EF666!134&authkey=!AAJIYLPWxrcp9mY&ithint=file,vmf, sorry about the messy link, Onedrive isn't the best.
     
  2. Kraken

    Kraken Few more zeros and ones for the site to proccess

    Messages:
    434
    Positive Ratings:
    115
    Try verifying your game cache.
    Seemed to work for the last person who had the same problem.
     
  3. MissionBrief_

    MissionBrief_ L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    Just verified my game cache with only 1 Broken file with no success, also recompiled the map.
     
  4. Egan

    aa Egan

    Messages:
    1,318
    Positive Ratings:
    1,507
    1) The initial info_player_teamspawn entities (for both teams) need their 'spawn for round' keyvalue set to the team_control_point_round entity in your map 'Round_A'. The other spawn points, forward spawns, spawns back at last, do not need this keyvalue set.

    [​IMG]

    2) You were missing a respawn room entity for Red on top of the first red spawn area.

    [​IMG]

    3) Your team_train_watcher is not set to handle the train movement which might lead to problems in your gametype. You have a capture point at the last area of the map so I'm not sure if you planned to have payload progress controlled by something else.

    [​IMG]

    4) Your team_control_point_master is also set up improperly specifically for PL but again I'm not sure if that's intended. It should be set up like this for PL:

    [​IMG]
     
    • Thanks Thanks x 2
  5. MissionBrief_

    MissionBrief_ L1: Registered

    Messages:
    9
    Positive Ratings:
    1
    Thank You Egan for the incredibly useful response, the map is working as expected and I even cleared up some over shoddy spawn entity work you might've noticed while looking through it, and in addressing points 3/4, I didn't even notice these at any point while working on my map, they work far better as you have done it. You might want to keep this link in a collection somewhere in case somebody else manages to have this issue, just link them here ;)