Odd Displacement Wireframe issue

Discussion in 'Mapping Questions & Discussion' started by SiniStarR, Jun 29, 2009.

  1. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
    Went into wireframe mode, and on some parts of my maps, the displacements show the way they should. But in others..its an entire different story, see for yourself.

    BEFORE WALKING:
    [​IMG]


    WALKING:
    [​IMG]

    [​IMG]

    [​IMG]

    Im sure its not a leak because my area portals run fine and the log doesn't mention anything about a leak and theres no visual problems either. Does anyone have an idea why it could be causing this?
     
  2. DJive

    aa DJive Cake or Death?

    Messages:
    1,466
    Positive Ratings:
    736
    hate to say it.. but it realllly looks like a leak =p
     
  3. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
    but then why wouldnt it effect anything?! both areaportal and visually? if it is a leak do you have any idea what would cause the leajk>
     
  4. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    It's not a leak. It's just an issue with the way wireframe mode works with displacements. It generally happens where there is no (or little) world geometry being rendered. Nothing you can do... deal with it :p
     
  5. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
    omg thank you so much ABS, i would have....well...not sure, but im glad to know its not me.
     
  6. Shmitz

    aa Shmitz Old Hat

    Messages:
    1,129
    Positive Ratings:
    740
    Yeah, you're getting the Hall of Mirrors effect because there is nothing being rendered beyond those displacements. The fact that it sometimes renders sky instead of HOM is just happenstance.
     
  7. SiniStarR

    SiniStarR L8: Fancy Shmancy Member

    Messages:
    585
    Positive Ratings:
    116
    so this wont effect the map in anyway its just an error with the wireframes am i right?
     
  8. TotalMark

    TotalMark L6: Sharp Member

    Messages:
    331
    Positive Ratings:
    40
    Yup, I get this all the time with mat_wireframe. It's really distracting when your trying to optimize.