Nuclear Waste Textures missing on packed map

  • Site Migration: See bugs? Report them here. Want something changed or have an idea? Suggest it here.

CPU Iris

L1: Registered
Jun 20, 2018
8
So I was having one of my friends test out my map if there weren't any weird visual bugs and errors and everything turned out fine until he fell into the nuclear waste pit on the parkour side of my map
(Note: the map was already compiled and all custom textures and models are packed INCLUDING the nuclear waste texture itself)

unknown.png


Here is the nuclear waste at the top which seems normal

unknown.png


And this is when he used the buddha command to go underneath the nuclear waste texture
(Note: btw the nuclear waste texture is a water texture)

I need help on how to fix this for my map.
Some suggest that I should just replace the texture with something else but I would really want to keep the theme of the map.

I would really appreciate any help or tips from you guys

(Note: this is my first map)

Edit: This is where I got the nuclear waste texture
https://tf2maps.net/downloads/nuclear-waste.381/
 
Last edited:

CPU Iris

L1: Registered
Jun 20, 2018
8
I have seen other maps with the nuclear waste texture and it worked fine for them like Crash's koth_trainsawlaser map
and there doesn't seem anything wrong with the texture in general.
 

henke37

aa
Sep 23, 2011
2,075
Now, the material on the other hand...
 

CPU Iris

L1: Registered
Jun 20, 2018
8
My speculation is that its probably because of the vmf files but im not completely sure and i have no knowledge of it whatsoever.

This is what's in the vmf files of the nuclear waste texture

nuclearwaste001.vmf

waste_vmf.JPG


nuclearwaste001_beneath.vmf

waste_underneath.vmf1.JPG

waste_underneath.vmf2.JPG
 
P

Prosciutto

you could use sv_pure 2 to see if the map is packed correctly iirc
 

CPU Iris

L1: Registered
Jun 20, 2018
8
Thanks for all the help guys~
The texture is working properly now for everyone and now I can publish the map for the server I play in